Period

Time Limit: 3000MS Memory Limit: 30000K

Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the
number zero on it.

Output

For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

题意:

输出2 <= i <= n中有多少个前缀有循环节,并且输出前缀个数,循环次数。

思路:

首先求出next数组,然后遍历一下求有多少个符合前缀符合有循环节的,这里参考:POJ 2406

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn = 1e+6 + 10;
char mo[maxn];
int Next[maxn];
void GetNext() {
    int i = 0, j = -1, len = strlen(mo);
    while (i < len) {
        if (j == -1 || mo[j] == mo[i]) Next[++i] = ++j;
        else j = Next[j];
    }
}
int main() {
    ios::sync_with_stdio(false);
    int n, Case = 1;
    while (scanf("%d", &n) != EOF && n) {
        scanf("%s", mo);
        Next[0] = -1;
        GetNext();
        printf("Test case #%d\n", Case++);
        for (int i = 2; i <= n; i++) {
            if (Next[i] > 0 && i % (i - Next[i]) == 0) printf("%d %d\n", i, i / (i - Next[i]));
        }
        printf("\n");
    }
    return 0;
}