题目描述

Given two strings a and b we define ab to be their concatenation. For example, if a = “abc” and b = “def” then ab = “abcdef”. If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = “” (the empty string) and a^(n+1) = a*(a^n).

输入

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

输出

For each s you should print the largest n such that s = a^n for some string a.

样例输入

abcd
aaaa
ababab
.

样例输出

1
4
3

代码

#include<iostream>
#include<string.h>
using namespace std;
int len,next[1000005];
char s[1000005];
void getnext()
{
    int j=-1;
    for (int i=0;i<len;i++)
    {
        while(j!=-1 && s[j+1]!=s[i]) j=next[j];
        if (s[j+1]==s[i] && i!=0) j++;
        next[i]=j;
    }
}
int main()
{
    while(cin>>s && s[0] != '.')
    {
        len=strlen(s);
        getnext();
        if (len%(len-next[len-1]-1)==0&&len!=next[len-1]+1)
        	cout<<(len/(len-next[len-1]-1))<<endl;
    }
    return 0;
}