Cow Picnic

Time Limit: 2000MS Memory Limit: 65536K

Description

The cows are having a picnic! Each of Farmer John’s K (1 ≤ K ≤ 100) cows is grazing in one of N (1 ≤ N ≤ 1,000) pastures, conveniently numbered 1…N. The pastures are connected by M (1 ≤ M ≤ 10,000) one-way paths (no path connects a pasture to itself).

The cows want to gather in the same pasture for their picnic, but (because of the one-way paths) some cows may only be able to get to some pastures. Help the cows out by figuring out how many pastures are reachable by all cows, and hence are possible picnic locations.

Input

Line 1: Three space-separated integers, respectively: K, N, and M
Lines 2…K+1: Line i+1 contains a single integer (1…N) which is the number of the pasture in which cow i is grazing.
Lines K+2…M+K+1: Each line contains two space-separated integers, respectively A and B (both 1…N and A != B), representing a one-way path from pasture A to pasture B.

Output

Line 1: The single integer that is the number of pastures that are reachable by all cows via the one-way paths.

Sample Input

2 4 4
2
3
1 2
1 4
2 3
3 4

Sample Output

2

Hint

The cows can meet in pastures 3 or 4.

思路:

邻接表加上dfs

#include <iostream>
#include <cstring>
#include <vector>
using namespace std;
int n, m, k;
vector<int> v[1010];
int book[1010] = {0};
bool cnt[1010] = {false};
void dfs(int x) {
	if (cnt[x] == true) return ;
	book[x]++;
	cnt[x] = true;
	for (int i = 0; i < v[x].size(); i++) {
		dfs(v[x][i]);
	}
}
int main() {
	int a[110];
	scanf("%d %d %d", &k, &n, &m);
	for (int i = 0; i < k; i++) scanf("%d", &a[i]);
	for (int i = 0; i < m; i++) {
		int a, b;
		scanf("%d %d", &a, &b);
		v[a].push_back(b); 
	}
	for (int i = 0; i < k; i++) {
		memset(cnt, false, sizeof(cnt));
		dfs(a[i]);
	}
	int sum = 0;
	for (int i = 0; i < 1010; i++) {
		if (book[i] == k) sum++;
	} 
	cout << sum << endl;
	return 0;
}