题目链接:http://poj.org/problem?id=2421
Time Limit: 2000MS Memory Limit: 65536K

Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j. 

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output

179

Problem solving report:

Description: 给出总共的村庄的编号,然后在下面的n行n列中,列举出来从i节点到j节点的所有的权值,之后再输入q表示有q组数据,表示接下来的q组数据表示已经连通,求出最后的最小生成树的最小权值!
Problem solving: 这道题是最小生成树问题,当已经连通时权值为0,然后跑一遍最小生成树prim算法。

Accepted Code:

/* 
 * @Author: lzyws739307453 
 * @Language: C++ 
 */
#include <queue>
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;
const int MAXN = 105;
const int inf = 0x3f3f3f3f;
bool vis[MAXN];
int dis[MAXN], mp[MAXN][MAXN];
struct edge {
    int v, w;
    edge() {}
    edge(int v, int w) : v(v), w(w) {}
    bool operator < (const edge &s) const {
        return s.w < w;
    }
};
int prim(int s, int n) {
    priority_queue <edge> Q;
    for (int i = 1; i <= n; i++) {
        vis[i] = 0;
        dis[i] = inf;
    }
    dis[s] = 0;
    Q.push(edge(s, dis[s]));
    int ans = 0;
    while (!Q.empty()) {
        edge u = Q.top();
        Q.pop();
        if (vis[u.v])
            continue;
        vis[u.v] = 1;
        ans += u.w;
        for (int j = 1; j <= n; j++) {
            if (!vis[j] && dis[j] > mp[u.v][j]) {
                dis[j] = mp[u.v][j];
                Q.push(edge(j, dis[j]));
            }
        }
    }
    return ans;
}
int main() {
    int n, m, u, v;
    while (~scanf("%d", &n)) {
        for (int i = 1; i <= n; i++)
            for (int j = 1; j <= n; j++)
                scanf("%d", &mp[i][j]);
        scanf("%d", &m);
        while (m--) {
            scanf("%d%d", &u, &v);
            mp[u][v] = mp[v][u] = 0;
        }
        printf("%d\n", prim(1, n));
    }
    return 0;
}