Problem Description
Steph is extremely obsessed with “sequence problems” that are usually seen on magazines: Given the sequence 11, 23, 30, 35, what is the next number? Steph always finds them too easy for such a genius like himself until one day Klay comes up with a problem and ask him about it.

Given two integer sequences {ai} and {bi} with the same length n, you are to find the next n numbers of {ai}: an+1…a2n. Just like always, there are some restrictions on an+1…a2n: for each number ai, you must choose a number bk from {bi}, and it must satisfy ai≤max{aj-j│bk≤j}, and any bk can’t be chosen more than once. Apparently, there are a great many possibilities, so you are required to find max{∑2nn+1ai} modulo 109+7 .

Now Steph finds it too hard to solve the problem, please help him.

Input
The input contains no more than 20 test cases.
For each test case, the first line consists of one integer n. The next line consists of n integers representing {ai}. And the third line consists of n integers representing {bi}.
1≤n≤250000, n≤a_i≤1500000, 1≤b_i≤n.

Output
For each test case, print the answer on one line: max{∑2nn+1ai} modulo 109+7。

Sample Input

4
8 11 8 5
3 1 4 2

Sample Output

27
Hint

For the first sample:
1. Choose 2 from {bi}, then a_2…a_4 are available for a_5, and you can let a_5=a_2-2=9;
2. Choose 1 from {bi}, then a_1…a_5 are available for a_6, and you can let a_6=a_2-2=9;

解法:一个显然的贪心就是我们区间越长得到的最大值越大,所以我们先把b排序,从小到大找当前取的b[j]到当前i位置的a[i]-i的最大值,这显然可以用mulitiset或者线段树来维护,维护了b[j]之后要把b[j]到b[j+1]之前的值都删除掉,因为有重复元素所以用了multiset。

复杂度:O(nlogn)

#include <bits/stdc++.h>
typedef long long LL;
using namespace std;
const LL huyu = 1e9 + 7;
const LL maxn = 300000;
LL a[maxn * 2];
LL b[maxn];
int main()
{
    LL n;
    while(~scanf("%lld", &n))
    {
        for(LL i = 1; i <= n; i++)
            scanf("%lld", &a[i]);
        for(LL i = 1; i <= n; i++)
            scanf("%lld", &b[i]);
        sort(b + 1, b + 1 + n);
        multiset<LL> s;
        for(LL i = 1; i <= n; i++)
            s.insert(a[i] - i);
        LL pos = 1;
        LL ans = 0;
        for(LL i = 1; i <= n; i++)
        {
            for(; pos < b[i]; pos++)
            {
                s.erase(s.find(a[pos] - pos));
            }
            LL tt = *s.rbegin();
            ans += tt;
            ans %= huyu;
            s.insert(tt - n - i);
        }
        ans %= huyu;
        if(ans < 0)
            ans += huyu;
        printf("%lld\n", ans);
    }
    return 0;
}