FATE
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 17655 Accepted Submission(s): 8292
Problem Description
最近xhd正在玩一款叫做FATE的游戏,为了得到极品装备,xhd在不停的杀怪做任务。久而久之xhd开始对杀怪产生的厌恶感,但又不得不通过杀怪来升完这最后一级。现在的问题是,xhd升掉最后一级还需n的经验值,xhd还留有m的忍耐度,每杀一个怪xhd会得到相应的经验,并减掉相应的忍耐度。当忍耐度降到0或者0以下时,xhd就不会玩这游戏。xhd还说了他最多只杀s只怪。请问他能升掉这最后一级吗?
Input
输入数据有多组,对于每组数据第一行输入n,m,k,s(0 < n,m,k,s < 100)四个正整数。分别表示还需的经验值,保留的忍耐度,怪的种数和最多的杀怪数。接下来输入k行数据。每行数据输入两个正整数a,b(0 < a,b < 20);分别表示杀掉一只这种怪xhd会得到的经验值和会减掉的忍耐度。(每种怪都有无数个)
Output
输出升完这级还能保留的最大忍耐度,如果无法升完这级输出-1。
Sample Input
10 10 1 10 1 1 10 10 1 9 1 1 9 10 2 10 1 1 2 2
Sample Output
0 -1 1
Author
Xhd
Source
这道题就是~一道两重限制的dp~我用ma[k][w],表示疲劳值使使用为k,打死的怪小于w时~能获得的最大的经验值是多少~~
扎样的话就能得出状态转移方程: ma[k][w]=max(ma[k][w],ma[k-endurance[s]][w-1]+experience[s]);
最后在松弛的过程中顺便检验看看有没有满足条件的方法就可以了~
#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<cstring>
using namespace std;
int experience[105],endurance[105];
int ma[105][105];
#define inf 0x3f3f3f3f
int main()
{
int max_experience,max_endurance,n,max_type;
while(cin>>max_experience>>max_endurance>>n>>max_type)
{
int minn=inf;
for(int s=1;s<=n;s++)
{
cin>>experience[s]>>endurance[s];
}
memset(ma,0,sizeof(ma));
for(int s=1;s<=n;s++)
{
for(int k=endurance[s];k<=max_endurance;k++)
{
for(int w=1;w<=max_type;w++)
{
ma[k][w]=max(ma[k][w],ma[k-endurance[s]][w-1]+experience[s]);
if(ma[k][w]>=max_experience&&minn>k)
{
minn=k;
}
}
}
}
if(minn==inf)
{
cout<<"-1"<<endl;
}
else
{
cout<<max_endurance-minn<<endl;
}
}
return 0;
}