Charm Bracelet

Time Limit: 1000MS Memory Limit: 65536K

Description

Bessie has gone to the mall’s jewelry store and spies a charm bracelet. Of course, she’d like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a ‘desirability’ factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

  • Line 1: Two space-separated integers: N and M
  • Lines 2…N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

  • Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

思路:

01背包模板题,只要把模板打完就完成了。

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn = 3500;
const int maxv = 13000;
int main() {
    int n, m, MAX = 0;
    int w[maxn], v[maxn], dp[maxv] = {0};
    scanf("%d %d", &n, &m);
    for (int i = 1; i <= n; i++) scanf("%d %d", &w[i], &v[i]);
    for (int i = 1; i <= n; i++) {
        for (int j = m; j >= w[i]; j--) {
            dp[j] = max(dp[j], dp[j - w[i]] +v[i]);
            MAX = max(MAX, dp[j]);
        }
    }
    printf("%d", MAX);
    return 0;
}