Find a multiple
Time Limit: 1000MS Memory Limit: 65536K
Special Judge
Description
The input contains N natural (i.e. positive integer) numbers ( N <= 10000 ). Each of that numbers is not greater than 15000. This numbers are not necessarily different (so it may happen that two or more of them will be equal). Your task is to choose a few of given numbers ( 1 <= few <= N ) so that the sum of chosen numbers is multiple for N (i.e. N * k = (sum of chosen numbers) for some natural number k).
Input
The first line of the input contains the single number N. Each of next N lines contains one number from the given set.
Output
In case your program decides that the target set of numbers can not be found it should print to the output the single number 0. Otherwise it should print the number of the chosen numbers in the first line followed by the chosen numbers themselves (on a separate line each) in arbitrary order.
If there are more than one set of numbers with required properties you should print to the output only one (preferably your favorite) of them.
Sample Input
5
1
2
3
4
1
Sample Output
2
2
3
思路:
鸽巢原理,题目要使相加的值能整除n,所以我们可以用前缀和的方式,比如开始x的时候模完为1,到了y点的时候也是1,那么中间相加的值肯定就是能整除n了,否则模完也不会相等,在n里面有n个数所以必有0 ~ n - 1中所以的话,肯定会出现这么一个连续的序列使最后的值能整除n。
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
const int maxn = 10010;
int sum[maxn], book[maxn], a[maxn];
int main() {
int n;
while (scanf("%d", &n) != EOF) {
memset(sum, 0, sizeof(sum));
memset(book, -1, sizeof(book));
int l = 0, r = 0;
book[0] = 0;
for (int i = 1; i <= n; i++) {
scanf("%d", &a[i]);
sum[i] = sum[i - 1] + a[i];
int temp = sum[i] % n;
if (book[temp] == -1) book[temp] = i;
else {
l = book[temp];
r = i;
}
}
printf("%d\n", r - l);
for (int i = l + 1; i <= r; i++) {
printf("%d\n", a[i]);
}
}
return 0;
}