Triangle LOVE
Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possibility that two people love each other, what a crazy world!
Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.
Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”.
Input
The first line contains a single integer t (1 <= t <= 15), the number of test cases.
For each case, the first line contains one integer N (0 < N <= 2000).
In the next N lines contain the adjacency matrix A of the relationship (without spaces). A i,j = 1 means i-th people loves j-th people, otherwise A i,j = 0.
It is guaranteed that the given relationship is a tournament, that is, A i,i= 0, Ai,j ≠ A j,i(1<=i, j<=n,i≠j).
Output
For each case, output the case number as shown and then print “Yes”, if there is a “Triangle Love” among these N people, otherwise print “No”.
Take the sample output for more details.
Sample Input
2
5
00100
10000
01001
11101
11000
5
01111
00000
01000
01100
01110
Sample Output
Case #1: Yes
Case #2: No
测试样例分析:
#include <cstdio>
#include <vector>
#include <queue>
#include <string.h>
#define MAX 2001
using namespace std;
int n,in[MAX];
vector <vector<int> > v;
bool toposort(){
int cnt=0;
queue <int> q;
//初始化,把所有入度为0的点入队
for(int i=0;i<n;i++){
if(in[i]==0) q.push(i);
}
while(!q.empty()){//当还有点未处理
int u=q.front(); q.pop(); //取出点并弹出队列
in[u]--;//in[u] = -1 标记该点已经弄过了
cnt++;//计数作用
for(int i=0;i<v[u].size();i++){
//将u所指向的所有点入度减一
int d=v[u][i];//d为所u指向的点
in[d]--;
if(in[d]==0){//如果这个过程中,入度变为0,则入队
q.push(d);
}
}
}
return cnt!=n;
}
int main(){
int t;//t组测试数据
scanf("%d",&t);
for(int i=1;i<=t;i++){
//初始化
v.clear();
scanf("%d",&n);
v.resize(n);//resize()用于设置大小(size)
memset(in,0,sizeof(in));
//输入数据并用容量vector保存
for(int j=0;j<n;j++){
char st[MAX];
scanf("%s",st);//输入一行数据
for(int k=0;k<n;k++){
if(st[k]=='1'){
//如果为1,就将k压入到j行中
v[j].push_back(k); //j-->k
in[k]++;// k的入度加一
}
}
}
printf("Case #%d: ",i);
bool hasCircle = toposort();
if(hasCircle)
printf("Yes\n");
else
printf("No\n");
}
return 0;
}