题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1004
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Problem Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you. 

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output

red
pink

Problem solving report:

Description: 有多种颜色的气球,统计它们的个数,并找出数量最多的那种颜色。 
Problem solving: 利用C++里面的map直接统计每个颜色出现的次数,然后找最大的就行了。

Accepted Code:

#include <bits/stdc++.h>
using namespace std;
int main() {
    int n;
    char str[20];
    while (scanf("%d", &n), n) {
        map <string, int> spt;
        for (int i = 0; i < n; i++) {
            scanf("%s", str);
            spt[str]++;
        }
        string s; 
        int max_ = 0;
        map <string, int>::iterator it;
        for (it = spt.begin(); it != spt.end(); it++) {
            if (it -> second > max_) {
                s = it -> first;
                max_ = it -> second;
            }
        }
        printf("%s\n", s.c_str());
    }
    return 0;
}