Max Sum

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 277191 Accepted Submission(s): 65811

Problem Description
Given a sequence a[1],a[2],a[3]……a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output
Case 1:
14 1 4

Case 2:
7 1 6

/************************************************************************* > File Name: Max_Sum.cpp > Author: shihao > Mail: 249083992@qq.com > Created Time: 2018年03月26日 星期一 14时22分34秒 ************************************************************************/

#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
    int N;
    int a[100000];
    scanf("%d", &N);
    for (int i = 1; i <= N; i++)    //使用i记录测试组号
    {
        int n;
        scanf("%d", &n);
        for (int j = 1; j <= n; j++)  //输入
        {
            scanf("%d", &a[j]); 
        }
        int sum = 0, max = a[1], start = 1, end = 1, temp = 1;  //temp用来记录起始位置
        for (int j = 1; j <= n; j++)
        {
            if (sum < 0)
            {
                temp = j;      //如果sum<0,记录起始位置
                sum = a[j];    
            }
            else
            {
                sum += a[j];
            }
            if (sum > max)      
            {
                max = sum;
                start = temp;
                end = j;
            }
        }
        printf("Case %d:\n", i);
        printf("%d %d %d\n", max, start, end);
        if (i < N)
        {
            printf("\n");
        }
    }
    return 0;
}