There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings. 

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0

Output

Output should contain the maximal sum of guests' ratings. 

Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output

5

 

   上级下级不能同时出现,每个人出现有着自己独特的值,问让出现的人的值综合最大是多少。

   这道题一看到上级下级,就会有人要建立有向图,其实不然,上级下级之间有的只是不能共存着一个特点而已,并没有像树一样需要你严格从上往下遍历,所以建立无向图之后随便找一个作为根遍历就好,注意加一个vis数组防止存在环。

#include<bits/stdc++.h>
using namespace std;
const int maxn = 20000;
struct fcuk {
	int u, v, ne;
}ed[maxn];
int n, head[maxn], cnt;
int v[maxn], dp[maxn][3], vis[maxn];
void init() {
	memset(dp, 0, sizeof(dp));
	memset(head, -1, sizeof(head));
	memset(vis, 0, sizeof(vis));
	cnt = 0;
}
void add(int u, int v) {
	ed[cnt].u = u; ed[cnt].v = v;
	ed[cnt].ne = head[u]; head[u] = cnt++;
}
void dfs(int x) {
	vis[x] = 1;
	dp[x][1] = v[x];
	for (int s = head[x]; ~s; s = ed[s].ne) {
		int v = ed[s].v;
		if (vis[v])continue;
		dfs(v);
		dp[x][0] += max(dp[v][1], dp[v][0]);
		dp[x][1] += dp[v][0];
	}
}
int main() {
	while (~scanf("%d", &n)) {
		init();
		for (int s = 1; s <= n; s++){
			scanf("%d", &v[s]);
		}
		int a, b;
		while (~scanf("%d%d", &a, &b) && a + b) {
			add(a, b); add(b, a);
		}
		dfs(1);
		int ans = max(dp[1][0], dp[1][1]);
		printf("%d\n", ans);
	}
}