I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
Sample Input
2 1 2 112233445566778899 998877665544332211
Sample Output
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
string sum(string ans,string b) {
if(ans.length()<b.length()) ans.swap(b);
for(int i=ans.length()-1,j=b.length()-1; i>=0; i--,j--) {
ans[i]=ans[i]+(j>=0?b[j]-'0':0);
if(ans[i]>'9') {
ans[i]-=10;
if(i>0) ans[i-1]++;
else ans.insert(0,"1");
}
}
return ans;
}
string a,b;
int main() {
int T;
cin>>T;
for(int k=1; k<=T; k++) {
cin>>a>>b;
cout<<"Case "<<k<<":"<<endl;
cout<<a<<" + "<<b<<" = "<<sum(a,b)<<endl;
if(k<T) cout<<endl;
}
return 0;
}