The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 
InputThe input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket. 
OutputFor each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets. 
Sample Input
1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0 
Sample Output
0
1
2
2

思路:方向是八个方向,每次对八个方向进行搜索,找到油田数量。找到了的油田可以把它变成‘*’或者标记一下 , 下次搜索的时候就可以直接跳过了。

虽然被无情嘲笑了, 但是,搜索好难啊~~~

下面代码:

#include <stdio.h>
#include <iostream>
using namespace std;
char data[100][100];
int n , m;
void dfs(int x , int y)
{
	data[x][y] = '*';
	int next[8][2] = {{0,1} , {1 , 1} , {1 , 0} , {1 , -1} , {0 , -1} , {-1 , -1} , {-1 , 0} , {-1 , 1}};
	for(int k = 0 ; k < 8 ; k++)
	{
		int tx = x + next[k][0];
		int ty = y + next[k][1];
		if(tx >= 0 && tx <= n && ty >= 0 && ty <= m)
		{
			if(data[tx][ty] == '@')
			{
				dfs(tx,ty);
			}
		}
	}
}
int main()
{
	while(~scanf("%d %d" , &n , &m) && (n+m))
	{
		int ans = 0;
		for(int i = 0 ; i < n ; i++)
		{
			for(int j = 0 ; j < m ; j++)
			{
				cin >> data[i][j];
			}
		}
		for(int i = 0 ; i < n ; i++)
		{
			for(int j = 0 ; j < m ; j++)
			{
				if(data[i][j] == '@')
				{
					dfs(i , j);
					ans++;
				}
			}
		}
		printf("%d\n" , ans);
	}
	return 0;
 }