Little A has come to college and majored in Computer and Science.
Today he has learned bit-operations in Algorithm Lessons, and he got a problem as homework.
Here is the problem:
You are giving n non-negative integers a1,a2,⋯,an, and some queries.
A query only contains a positive integer p, which means you
are asked to answer the result of bit-operations (and, or, xor) of all the integers except apap.
Input
There are no more than 15 test cases.
Each test case begins with two positive integers n and p
in a line, indicate the number of positive integers and the number of queries.
2≤n,q≤10^5
Then n non-negative integers a1,a2,⋯,an follows in a line, 0≤ai≤10^9 for each i in range[1,n].
After that there are q positive integers p1,p2,⋯,pq in q lines, 1≤pi≤n for each i in range[1,q].
Output
For each query p, output three non-negative integers indicates the result of bit-operations(and, or, xor) of all non-negative integers except apap in a line.
Sample Input
3 3
1 1 1
1
2
3
Sample Output
1 1 0
1 1 0
1 1 0
位运算,前缀后缀
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn=1e5+5;
typedef long long ll;
ll a[maxn],yu1[maxn],yu2[maxn],huo1[maxn],huo2[maxn];
int main(){
int n,q;
while(~scanf("%d%d",&n,&q)){
int k=0;
for(int i=1;i<=n;i++){
scanf("%lld",&a[i]);
k^=a[i];
}
yu1[1]=huo1[1]=a[1];
for(int i=2;i<=n;i++){
yu1[i]=yu1[i-1]&a[i];
huo1[i]=huo1[i-1]|a[i];
}
yu2[n]=huo2[n]=a[n];
for(int i=n-1;i>=1;i--){
yu2[i]=yu2[i+1]&a[i];
huo2[i]=huo2[i+1]|a[i];
}
int p;
for(int i=1;i<=q;i++){
scanf("%d",&p);
if(p==1) printf("%d %d %d\n",yu2[p+1],huo2[p+1],k^a[p]);
else if(p==n) printf("%d %d %d\n",yu1[p-1],huo1[p-1],k^a[p]);
else
printf("%d %d %d\n",yu1[p-1]&yu2[p+1],huo1[p-1]|huo2[p+1],k^a[p]);
}
}
return 0;
}