A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example, 

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10 

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each. 

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine. 

Notes: 
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc. 

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format: 

cash N n1 D1 n2 D2 ... nN DN 

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct. 

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below. 

Sample Input

735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10

Sample Output

735
630
0
0

Hint

The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash. 

In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash. 

In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.

题意:给出一个目标值和一个货币种类数,然后再给出每种货币的信息,信息有(数量和面值),求出不超过目标值的最大能凑成的面值。

题解:有规定数量所以为多重背包题目,常规写法,三层for循环会超时,所以用到,多重背包二进制优化,详细过程请看代码:

 

#include <iostream>
#include <cstring>
using namespace std;
const int MAX = 100000+10;
int dp[MAX],k,a[MAX];
int main(){
	int vv;
	while(cin >> vv){
		memset(dp,0,sizeof(dp));
		int n;
		cin >> n;
		int z=0;
		for (int i = 0; i < n;i++){
			int x,y;
			cin >> x >> y;
			k=1; // 从 2^0开始 	
            while(x>0){ // 2进制优化转01背包 记住啊啊啊 
            	if(x>=k){
            		a[z++]=k*y;
            		x-=k;
            		k<<=1;
				}
				else{
					a[z++]=x*y;
					break;
				} 
			}        
		}
		for (int i = 0; i < z;i++){//01背包模板 
			for (int j = vv; j >= a[i];j--){
				dp[j]=max(dp[j],dp[j-a[i]]+a[i]);
			}
		}
		cout << dp[vv] << endl;
	}
	return 0;
}