过山车

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Problem Description

RPG girls今天和大家一起去游乐场玩,终于可以坐上梦寐以求的过山车了。可是,过山车的每一排只有两个座位,而且还有条不成文的规矩,就是每个女生必须找个个男生做partner和她同坐。但是,每个女孩都有各自的想法,举个例子把,Rabbit只愿意和XHD或PQK做partner,Grass只愿意和linle或LL做partner,PrincessSnow愿意和水域浪子或伪酷儿做partner。考虑到经费问题,boss刘决定只让找到partner的人去坐过山车,其他的人,嘿嘿,就站在下面看着吧。聪明的Acmer,你可以帮忙算算最多有多少对组合可以坐上过山车吗?

Input

输入数据的第一行是三个整数K , M , N,分别表示可能的组合数目,女生的人数,男生的人数。0<K<=1000
1<=N 和M<=500.接下来的K行,每行有两个数,分别表示女生Ai愿意和男生Bj做partner。最后一个0结束输入。

Output

对于每组数据,输出一个整数,表示可以坐上过山车的最多组合数。

Sample Input

6 3 3
1 1
1 2
1 3
2 1
2 3
3 1
0

Sample Output

3

邻接矩阵版

思路:

匈牙利算法的裸题,只要写个匈牙利算法就行了。

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn = 510;
int nxt[maxn];
bool use[maxn],line[maxn][maxn];
int k, n, m;
bool Find(int x) {
    for (int i = 1; i <= m; i++) {
        if (line[x][i] && !use[i]) {
            use[i] = true;
            if (nxt[i] == 0 || Find(nxt[i])) {
                nxt[i] = x;
                return true;
            }
        }
    }
    return false;
}
int main() {
    ios::sync_with_stdio(false);
    while (scanf("%d", &k) != EOF && k) {
        scanf("%d %d", &n, &m);
        memset(line, false, sizeof(line));
        memset(nxt, 0, sizeof(nxt));
        while (k--) {
            int a, b;
            scanf("%d %d", &a, &b);
            line[a][b] = true;
        }
        int sum = 0;
        for (int i = 1; i <= n; i++) {
            memset(use, false, sizeof(use));
            if (Find(i)) sum++;
        }
        printf("%d\n", sum);
    }
    return 0;
}

邻接表版

#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
using namespace std;
const int maxn = 510;
vector<int> line[maxn];
int nxt[maxn];
bool use[maxn];
int k, n, m;
bool Find(int x) {
    for (int i = 0; i < line[x].size(); i++) {
        int temp = line[x][i];
        if (!use[temp]) {
            use[temp] = true;
            if (nxt[temp] == 0 || Find(nxt[temp])) {
                nxt[temp] = x;
                return true;
            }
        }
    }
    return false;
}
int main() {
    ios::sync_with_stdio(false);
    while (scanf("%d", &k) != EOF && k) {
        scanf("%d %d", &n, &m);
        memset(nxt, 0, sizeof(nxt));
        for (int i = 0; i < maxn; i++) line[i].clear();
        while (k--) {
            int a, b;
            scanf("%d %d", &a, &b);
            line[a].push_back(b);
        }
        int sum = 0;
        for (int i = 1; i <= n; i++) {
            memset(use, false, sizeof(use));
            if (Find(i)) sum++;
        }
        printf("%d\n", sum);
    }
    return 0;
}