Duizi and Shunzi
Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 1795 Accepted Submission(s): 719
Problem Description
Nike likes playing cards and makes a problem of it.
Now give you n integers, ai(1≤i≤n)
We define two identical numbers (eg: 2,2) a Duizi,
and three consecutive positive integers (eg: 2,3,4) a Shunzi.
Now you want to use these integers to form Shunzi and Duizi as many as possible.
Let s be the total number of the Shunzi and the Duizi you formed.
Try to calculate max(s).
Each number can be used only once.
Now give you n integers, ai(1≤i≤n)
We define two identical numbers (eg: 2,2) a Duizi,
and three consecutive positive integers (eg: 2,3,4) a Shunzi.
Now you want to use these integers to form Shunzi and Duizi as many as possible.
Let s be the total number of the Shunzi and the Duizi you formed.
Try to calculate max(s).
Each number can be used only once.
Input
The input contains several test cases.
For each test case, the first line contains one integer n( 1≤n≤106).
Then the next line contains n space-separated integers ai ( 1≤ai≤n)
For each test case, the first line contains one integer n( 1≤n≤106).
Then the next line contains n space-separated integers ai ( 1≤ai≤n)
Output
For each test case, output the answer in a line.
Sample Input
7 1 2 3 4 5 6 7 9 1 1 1 2 2 2 3 3 3 6 2 2 3 3 3 3 6 1 2 3 3 4 5
Sample Output
2 4 3 2
Hint
Case 1(1,2,3)(4,5,6) Case 2(1,2,3)(1,1)(2,2)(3,3) Case 3(2,2)(3,3)(3,3) Case 4(1,2,3)(3,4,5) Source
Recommend
这道题用贪心来做就好~~
#include<iostream>
#include<cstdio>
using namespace std;
int sum[1000005];
int main()
{
int n;
int maxn=0;
while (cin >> n)
{
memset(sum, 0, sizeof(sum));
for (int s = 0; s < n; s++)
{
int w;
scanf("%d", &w);
if (w > maxn)
{
maxn = w;
}
sum[w]++;
}
int ans = 0;
for (int s = 1; s <= maxn; s++)
{
int te = sum[s] / 2;
// cout << te << endl;
ans += te;
sum[s] %= 2;
if (sum[s]==1&&sum[s + 1] % 2 == 1 && sum[s + 2] > 0)
{
ans++;
// cout << s << endl;
sum[s]--;
sum[s + 1]--;
sum[s + 2]--;
}
}
cout << ans << endl;
}
return 0;
}