Fibonacci Again

链接:http://acm.hdu.edu.cn/showproblem.php?pid=1021

Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

Output
Print the word “yes” if 3 divide evenly into F(n).

Print the word “no” if not.

Sample Input
0
1
2
3
4
5

Sample Output
no
no
yes
no
no
no

该题只需直接计算并对三取模即可

#include <bits/stdc++.h>
using namespace std;
int f[1000005];
int main()
{
    f[0]=1,f[1]=2;
    for(int i=2;i<1000000;i++){
        f[i]=(f[i-1]+f[i-2])%3;
    }
    int n;
    while(cin>>n){
        if(f[n]!=0)cout<<"no"<<endl;
        else cout<<"yes"<<endl;
    }
    return 0;
}