题目链接:http://acm.hdu.edu.cn/diy/contest_showproblem.php?pid=1001&cid=35083

Problem Description

The Power Cube is used as a stash of Exotic Power. There are n cities numbered 1,2,…,n where allowed to trade it. The trading price of the Power Cube in the i-th city is ai dollars per cube. Noswal is a foxy businessman and wants to quietly make a fortune by buying and reselling Power Cubes. To avoid being discovered by the police, Noswal will go to the i-th city and choose exactly one of the following three options on the i-th day:

1. spend 
ai dollars to buy a Power Cube
2. resell a Power Cube and get 
ai dollars if he has at least one Power Cube
3. do nothing

Obviously, Noswal can own more than one Power Cubes at the same time. After going to the 
n cities, he will go back home and stay away from the cops. He wants to know the maximum profit he can earn. In the meanwhile, to lower the risks, he wants to minimize the times of trading (include buy and sell) to get the maximum profit. Noswal is a foxy and successful businessman so you can assume that he has infinity money at the beginning.

Input

There are multiple test cases. The first line of input contains a positive integer T (T250), indicating the number of test cases. For each test case:
The first line has an integer 
n. (1n105)
The second line has 
n integers a1,a2,…,an where ai means the trading price (buy or sell) of the Power Cube in the i-th city. (1ai109)
It is guaranteed that the sum of all 
n is no more than 5×105.

Output

For each case, print one line with two integers —— the maximum profit and the minimum times of trading to get the maximum profit.

Sample Input

3
4
1 2 10 9
5
9 5 9 10 5
2
2 1

Sample Output

16 4
5 2
0 0

Hint

In the first case, he will buy in 1, 2 and resell in 3, 4. profit = - 1 - 2 + 10 + 9 = 16
In the second case, he will buy in 2 and resell in 4. profit = - 5 + 10 = 5
In the third case, he will do nothing and earn nothing. profit = 0

 

思路:优先队列,除了第一个,只要遇到w>kong.top(),就入2次列,因为不一定是w卖出的,入2次等于没卖。好比a-c=a-b+b-c,这里的b就入了2次,一次是a价格的物品以b价格卖出,还有一次是b价格的物品以c价格卖出,这b等于没有用,这样就可以避免卖错地方了。

次数用map去记录,因为数组开不到1e9那么大,只要pop之前判断队列里有没有存在2个一样的值就可以,有不动,没有cishu+=2(一卖一入)。

 


 

#include<bits/stdc++.h>

using namespace std;

#define ll long long

map<int,int >a;

priority_queue<int,vector<int>,greater<int> >kong;

int main()

{

         int t;

         cin>>t;

         while(t--)

         {

                   a.clear();

                   while(!kong.empty())kong.pop();//初始化优先队列

                   int n,w;

                   cin>>n;

                   ll ans=0;

                   ll cishu=0;

                   for(int i=1;i<=n;i++)

                   {

                            cin>>w;

                            if(!kong.empty()&&w>kong.top())//卖出能赚且队列不空

                            {

                                     if(a[kong.top()])a[kong.top()]--;//入2个的用掉了

                                     else cishu+=2;

                                     a[w]++;//w入列2个几次了(每入列2个算1次)

                                     ans+=w-kong.top();//累加算赚的总和

                                     kong.pop();

                                     kong.push(w);

                            }

                            kong.push(w);

                   }

                   cout<<ans<<" ";

                   cout<<cishu<<endl;

         }       

 }