题干:

Andy, 8, has a dream - he wants to produce his very own dictionary. This is not an easy task for him, as the number of words that he knows is, well, not quite enough. Instead of thinking up all the words himself, he has a briliant idea. From his bookshelf he would pick one of his favourite story books, from which he would copy out all the distinct words. By arranging the words in alphabetical order, he is done! Of course, it is a really time-consuming job, and this is where a computer program is helpful.

You are asked to write a program that lists all the different words in the input text. In this problem, a word is defined as a consecutive sequence of alphabets, in upper and/or lower case. Words with only one letter are also to be considered. Furthermore, your program must be CaSe InSeNsItIvE. For example, words like "Apple", "apple" or "APPLE" must be considered the same.

 

Input

The input file is a text with no more than 5000 lines. An input line has at most 200 characters. Input is terminated by EOF.

 

Output

Your output should give a list of different words that appears in the input text, one in a line. The words should all be in lower case, sorted in alphabetical order. You can be sure that he number of distinct words in the text does not exceed 5000.

 

Sample Input

Adventures in Disneyland

Two blondes were going to Disneyland when they came to a fork in the
road. The sign read: "Disneyland Left."

So they went home.

 

Sample Output

a
adventures
blondes
came
disneyland
fork
going
home
in
left
read
road
sign
so
the
they
to
two
went
were
when

题目大意:

   输入一个文本,找出所有不同的单词(连续的字母序列),按字典序升序输出。单词不区分大小写。

解题报告:

     使用STL的set自动去重+排序的优势,并且这里使用了流处理sstream,将读入的文章整合成只含有小写字母和空格的字符串。黑科技啊!注意啊这题如果用map映射字符串的话,首先你要形成字符串所以需要在每个字符串后加  ' \0 ' !

AC代码:(20ms)

#include<iostream>
#include<string>
#include<set>
#include<sstream>
using namespace std;
 
set<string> st;
set<string>::iterator it;
int main()
{
        std::ios::sync_with_stdio(false);
	string s,buf;
	while(cin>>s)  
	{
		for(int i=0;i<s.length();i++)
		{
			if(isalpha(s[i]))
			    s[i]=tolower(s[i]);
			else
			    s[i]=' '; //将输入的非字符转换为空格,作为单词的分界点。 
		} 
		stringstream ss(s);//导入流ss中 注意格式
		while(ss>>buf)
		st.insert(buf);//从流里导出标准的string类(因为前面已经整合好了)
	}
	for(it=st.begin();it!=st.end();it++)
	    cout<<*it<<"\n";
    return 0;
} 

加上这行std::ios::sync_with_stdio(false);并没快多少啊

注意字符串有的时候需要自己填 ' \0 ' 有的时候会忘掉