题目链接:传送门

Problem Description

Eddy's interest is very extensive, recently he is interested in prime number. Eddy discover the all number owned can be divided into the multiply of prime number, but he can't write program, so Eddy has to ask intelligent you to help him, he asks you to write a program which can do the number to divided into the multiply of prime number factor .

Input

The input will contain a number 1 < x<= 65535 per line representing the number of elements of the set.

Output

You have to print a line in the output for each entry with the answer to the previous question.

Sample Input

11
9412

Sample Output

11
2*2*13*181

题目大意:给出一个数,求这个数由哪些素数相乘得到.

#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
int m[65535];
int ss(int a)
{
    int c,d,e,f;
    for(c=2;c<=sqrt(a);c++)
    {
        if(a%c==0)
            return 0;
    }
    return 1;
}
int main()
{
    int a,b,c,d,e,f;
    b=0;
    for(a=2;a<=65535;a++)
    {
        if(ss(a)==1)
            m[b++]=a;
    }
    while(cin>>c)
    {
        d=0;
        while(c)
        {
            if(c%m[d]==0)
            {
                cout<<m[d];
                if(c==m[d])
                    cout<<endl;
                else
                    cout<<"*";
                c=c/m[d];
            }
            else
                d++;
            if(c==1)
                break;
        }
    }
    return 0;
}