Edward, a poor copy typist, is a user of the Dvorak Layout. But now he has only a QWERTY Keyboard with a broken <kbd style="border&#58;1px solid rgb&#40;170&#44;170&#44;170&#41;&#59;font&#45;family&#58;inherit&#59;font&#45;size&#58;&#46;85em&#59;">Caps Lock</kbd> key, so Edward never presses the broken <kbd style="border&#58;1px solid rgb&#40;170&#44;170&#44;170&#41;&#59;font&#45;family&#58;inherit&#59;font&#45;size&#58;&#46;85em&#59;">Caps Lock</kbd> key. Luckily, all the other keys on the QWERTY keyboard work well. Every day, he has a lot of documents to type. Thus he needs a converter to translate QWERTY into Dvorak. Can you help him?

The QWERTY Layout and the Dvorak Layout are in the following:

The QWERTY Layout

The Dvorak Layout

Input

A QWERTY document Edward typed. The document has no more than 100 kibibytes. And there are no invalid characters in the document.

Output

The Dvorak document.

Sample Input

Jgw Gqm Andpw a H.soav Patsfk f;doeNfk Gq.d slpt a X,dokt vdtnsaoheKjd yspps,glu pgld; aod yso kd;kgluZ1234567890`~!@#$%^&*()}"']_+-=ZQqWEwe{[\|ANIHDYf.,bt/ABCDEFuvwxyz

Sample Output

Hi, I'm Abel, a Dvorak Layout user.But I've only a Qwerty keyboard.The following lines are for testing:1234567890`~!@#$%^&*()+_-={}[]:"'<>,.?/\|ABCDEFuvwxyzAXJE>Ugk,qf;



本来这个题会做,然后交错了三十次,赛后找到了原因:
我把100KB 
当成了100B!!!!!
 
 所以数组开的很小,用gets的时候会
Segmentation Fault(非法内存)
 用getline虽然安全,但是我限定一行最多1100个字符,不错才怪!
所以,以后千万不能马虎!不仅坏了大事,而且还影响心情!!
当时正在比赛,结果被这个题搞的做不下去了!!

不多说,贴代码如下:


#include<stdio.h>
#include<iostream>
#include<cstring>
#include<stdlib.h>
using namespace std;
const char p[1000]="~`!1@2#3$4%5^6&7*80_-+=WwEeRrTtYyUuIiOoPp{[}]|\\AaSsDdFfGgHhJjKkLl:;ZzXxCcVvBbNnMm<,>.?/\0";
const char q[1000]="~`!1@2#3$4%5^6&7*80{[}]<,>.PpYyFfGgCcRrLl?/+=|\\AaOoEeUuIiDdHhTtNnSs:;QqJjKkXxBbMmWwVvZz\0";
int main()
{
    char Q[110000];
    memset(Q,0,sizeof(Q));
    while(cin.getline(Q,1100000))
    {
        int i=0,t;
        while(i<strlen(Q))
            {t=0;
            if(Q[i]=='Q'){Q[i]='\"';t=1;}
            else if(Q[i]=='q'){Q[i]='\'';t=1;}
            else if(Q[i]=='"'){Q[i]='_';t=1;}
            else if(Q[i]=='\''){Q[i]='-';t=1;}
            if(t==0)
            {for(int j=0;j<strlen(p);j++)
            {
                if(Q[i]==p[j])
                {
                    Q[i]=q[j];
                    break;
                }
            }}
            i++;
            }
    cout<<Q<<endl;
}
}