题干:

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket. 
 

Output

are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output

0
1
2
2

解题报告:

     注意这题在写的时候,dfs中一定要先maze[][]='*',而不能后序赋值, 这样就会进入死循环,第二个样例就可以很明显的看出来.

AC代码:

#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
int n,m;
char maze[105][105];
int nx[8] = {0,1,1,1,0,-1,-1,-1};
int ny[8] = {1,1,0,-1,-1,-1,0,1};
void dfs(int x,int y) {
	if(x < 1 ||x > n || y <1 || y > m) return ;
//	if(maze[x][y] == '*') return ;
	for(int k = 0; k<8; k++) {
		int tx = x+nx[k];
		int ty = y+ny[k];
		if(maze[tx][ty] == '@') {
			maze[tx][ty] = '*';dfs(tx,ty);
		}
	}
//	maze[x][y] = '*';
	
}
int main()
{

	while(cin>>n>>m) {
		if(n == 0 && m == 0) break;
		int cnt = 0;
		for(int i = 1; i<=n; i++) {
			scanf("%s",maze[i] + 1);
		}
		for(int i = 1; i<=n; i++) {
			for(int j = 1; j<=m; j++) {
				if(maze[i][j] == '@') {
					maze[i][j] = '*';
					dfs(i,j);cnt++;
				}
			}
		}
		cout << cnt <<endl;
	}
	
	return 0 ;
 }