题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1237
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Problem Description
读入一个只包含 +, -, *, / 的非负整数计算表达式,计算该表达式的值。
Input
测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,整数和运算符之间用一个空格分隔。没有非法表达式。当一行中只有0时输入结束,相应的结果不要输出。
Output
对每个测试用例输出1行,即该表达式的值,精确到小数点后2位。
Sample Input
1 + 2
4 + 2 * 5 - 7 / 11
0
Sample Output
3.00
13.36
Problem solving report:
Description: 计算表达式,计算该表达式的值。
Problem solving: 遇到'+'、'-'就入栈,遇到'*'、'/'就直接运算,最后再计算栈中元素的和。
Accepted Code:
#include <bits/stdc++.h>
using namespace std;
typedef double ElemType;
typedef struct ListPtr {
ElemType data;
ListPtr *prior;
}*lists;
int len;
lists head, tail;
void Alloc(lists &p) {
p = (ListPtr *)malloc(sizeof(ListPtr));
p -> prior = NULL;
}
void link() {
len = 0;
Alloc(head);
tail = head;
}
void push(ElemType e) {
lists p;
Alloc(p);
p -> data = e;
p -> prior = tail;
tail = p;
len++;
}
void pop() {
len--;
lists p = tail;
tail = tail -> prior;
free(p);
}
ElemType top() {
return tail -> data;
}
int main() {
char ch, opt;
ElemType a, b, ans;
while (scanf("%lf%c", &a, &ch)) {
if (!a && ch == '\n')//结束条件
break;
link();
push(a);
while (scanf("%c%lf", &opt, &b)) {
if (opt == '+')
push(b);
else if (opt == '-')
push(-b);//看成+(-b)
else if (opt == '*') {
b = top() * b;
pop();
push(b);
}
else if (opt == '/') {
b = top() / b;
pop();
push(b);
}
ch = getchar();
if (ch == '\n')
break;
}
ans = 0;
while (len) {
ans += top();
pop();
}
printf("%.2lf\n", ans);
}
return 0;
}