题目链接:https://vjudge.net/problem/POJ-2406
Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd aaaa ababab .
Sample Output
1 4 3
Hint
This problem has huge input, use scanf instead of cin to avoid time limit exceed.
题意:求字符串是由最小循环节循环几次得到的
#include<cstdio>
#include<cstring>
using namespace std;
const int N=1e6+5;
char s[N];
int next[N];
void getnext(int len) {
int j=-1;
next[0]=-1;
for(int i=1; i<len; i++) {
while(j!=-1&&s[i]!=s[j+1])
j=next[j];
if(s[i]==s[j+1])
j++;
next[i]=j;
}
}
int main() {
int Case=0;
while(~scanf("%s",s)){
if(s[0]=='.') break;
int len=strlen(s);
getnext(len);
int x=len-(next[len-1]+1);//循环节
if(len%x==0)
printf("%d\n",len/x);
else
printf("1\n");
}
return 0;
}