Can you answer these queries?

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 35343    Accepted Submission(s): 8500

Problem Description
A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

Notice that the square root operation should be rounded down to integer.
 
Input
The input contains several test cases, terminated by EOF.
  For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
  The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 263.
  The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
  For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.
 
Output
For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.
 

 

Sample Input
 
10
1 2 3 4 5 6 7 8 9 10
5
0 1 10
1 1 10
1 1 5
0 5 8
1 4 8

 

Sample Output
Case #1:
19
7
6

思路:开根号开不了几次后就是1的,如果tree[k].sum == tree[k].r - tree[k].l + 1,说明不用开根号的,之后类似单点修改

代码:
 

#include<bits/stdc++.h>
using namespace std;
#define ll long long
#pragma warning(disable:4996)
struct Node
{
	ll l, r;
	ll lazy = 0, sum = 0, mlz = 1;
}tree[500005];
ll input[500005];
int n, m;
void build(int k, int l, int r)
{
	tree[k].l = l, tree[k].r = r;
	if (l == r)
	{
		tree[k].sum = input[l]; return;
	}
	int mid = (l + r) >> 1;
	build(2 * k, l, mid);
	build(2 * k + 1, mid + 1, r);
	tree[k].sum = (tree[2 * k].sum + tree[2 * k + 1].sum);
}
ll query(int k, ll l, ll r)
{
	if (tree[k].l == l && tree[k].r == r)
	{
		return tree[k].sum;
	}
	//pushup(k);
	int mid = (tree[k].l + tree[k].r) >> 1;
	if (mid >= r)return query(2 * k, l, r);
	if (mid < l)return query(2 * k + 1, l, r);
	return (query(2 * k, l, mid)+ query(2 * k + 1, mid + 1, r));
}
void Sqrt(ll k, ll l, ll r)
{
	if (tree[k].sum == tree[k].r - tree[k].l + 1)return;
	if (tree[k].l == tree[k].r )
	{
		tree[k].sum = (ll)sqrt(tree[k].sum);
		return;
	}
	int mid = (tree[k].l + tree[k].r) >> 1;
	if (mid >= r)Sqrt(2 * k, l, r);
	else if (mid < l)Sqrt(2 * k + 1, l, r);
	else Sqrt(2 * k, l, mid), Sqrt(2 * k + 1, mid + 1, r);
	tree[k].sum = (tree[2 * k].sum + tree[2 * k + 1].sum);
}
int main()
{
	int xxx = 1;
	while (~scanf("%d", &n))
	{
		for (int i = 1; i <= n; i++)scanf("%lld", &input[i]);
		scanf("%d", &m);
		printf("Case #%d:\n", xxx++);
		build(1, 1, n);
		while (m--)
		{
			int a, b, c;
			scanf("%d%d%d", &a, &b, &c);
			if (b > c)swap(b, c);
			if (a == 0)
			{
				Sqrt(1, b, c);
			}
			else
			{
				printf("%lld\n", query(1, b, c));
			}
		}
		printf("\n");
	}
}