The zoo have N cats and M dogs, today there are P children visiting the zoo, each child has a like-animal and a dislike-animal, if the child's like-animal is a cat, then his/hers dislike-animal must be a dog, and vice versa.
Now the zoo administrator is removing some animals, if one child's like-animal is not removed and his/hers dislike-animal is removed, he/she will be happy. So the administrator wants to know which animals he should remove to make maximum number of happy children.

Input

The input file contains multiple test cases, for each case, the first line contains three integers N <= 100, M <= 100 and P <= 500.
Next P lines, each line contains a child's like-animal and dislike-animal, C for cat and D for dog. (See sample for details)

Output

For each case, output a single integer: the maximum number of happy children.

Sample Input

1 1 2
C1 D1
D1 C1

1 2 4
C1 D1
C1 D1
C1 D2
D2 C1

Sample Output

1
3


        
  

Hint

Case 2: Remove D1 and D2, that makes child 1, 2, 3 happy.
        
题意:

       动物园里有猫和狗,不同的小朋友喜欢不同的小动物,把他们不喜欢的小动物拿走他们就会开心,求最多能使多少小朋友开心。

思路:

       把喜好相反的小朋友存入二分图中,再求最大独立集。

       最大独立集 = 顶点数 - 最大匹配数

代码:

#include<stdio.h>
#include<string.h>
int map[1010][1010],book[1010],match[1010];
int n,m,p;
int dfs(int u)
{
	int i;
	for(i=1;i<=p;i++)
	{
		if(book[i]==0&&map[u][i]==1)
		{
			book[i]=1;
			if(match[i]==0||dfs(match[i]))
			{
				match[i]=u; 
				return 1;
			}
		}
	}
	return 0;
}
int main()
{
	int i,j,sum,s;
	char a[510][20],b[510][20];
	while(scanf("%d%d%d",&n,&m,&p)!=EOF)
	{
		memset(map,0,sizeof(map));
		memset(match,0,sizeof(match));
		s=sum=0;
		getchar();
		for(i=1;i<=p;i++)
			scanf("%s%s",a[i],b[i]);
			
		for(i=1;i<=p;i++)
        	for(j=1;j<=p;j++)
	       {
	           if(strcmp(a[i],b[j])==0||strcmp(a[j],b[i])==0)
	           map[i][j]=1;
	       }
		for(i=1;i<=p;i++)
		{
			memset(book,0,sizeof(book));
			if(dfs(i))
				sum++;
		}
		printf("%d\n",p-sum/2); 
	}
	return 0;
}