Girls and Boys

Problem Description

the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.

Sample Input

7

0: (3) 4 5 6

1: (2) 4 6

2: (0)

3: (0)

4: (2) 0 1

5: (1) 0

6: (2) 0 1

3

0: (2) 1 2

1: (1) 0

2: (1) 0

Sample Output

5

2

题意描述:

共有n名同学,0---n-1,给出每个编号的同学和那几个编号的同学有关系,求出没有关系的最大同学数;(最大独立集)

解题思路:
利用二分匹配求出最大匹配数,因存储时存储为双向,n-sum/2得到最大独立集。

#include<stdio.h>
#include<string.h>
int e[510][510],book[510],match[510];
int  n;
int dfs(int u)
{
	int i;
	for(i=0;i<n;i++)
	{
		if(book[i]==0&&e[u][i]==1)
		{
			
			book[i]=1;
			if(match[i]==0||dfs(match[i]))
			{
				match[i]=u;
				return 1;
			}
		}
	}
	return 0;
}
int main()
{
	int x,a,i,j,k,q,sum;
	while(scanf("%d",&n)!=EOF)
	{
		memset(e,0,sizeof(e));
		for(i=0;i<=n-1;i++)
		{
			scanf("%d: (%d)",&q,&k);
			for(j=1;j<=k;j++)
			{
				scanf("%d",&a);
				e[q][a]=1;
			}
		}
		sum=0;
		memset(match,0,sizeof(match));
		for(i=0;i<n;i++)
		{
			memset(book,0,sizeof(book));
			if(dfs(i))
				sum++;
		}
		printf("%d\n",n-(sum/2));
	}
	return 0;
}