• 370通过
    • 1<small style="font&#45;size&#58;&#46;5em&#59;">K</small>提交
  • 题目提供者FarmerJohn2
  • 评测方式云端评测
  • 标签USACO2006
  • 难度提高+/省选-
  • 时空限制1000ms / 128MB
【P2865】[USACO06NOV]路障Roadblocks - 洛谷 https://www.luogu.org/problemnew/show/P2865

题目描述

Bessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the shortest path. She knows there must be some second-shortest path.

The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤ N ≤ 5000) intersections, conveniently numbered 1..N. Bessie starts at intersection 1, and her friend (the destination) is at intersection N.

The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path).

贝茜把家搬到了一个小农场,但她常常回到FJ的农场去拜访她的朋友。贝茜很喜欢路边的风景,不想那么快地结束她的旅途,于是她每次回农场,都会选择第二短的路径,而不象我们所习惯的那样,选择最短路。 贝茜所在的乡村有R(1<=R<=100,000)条双向道路,每条路都联结了所有的N(1<=N<=5000)个农场中的某两个。贝茜居住在农场1,她的朋友们居住在农场N(即贝茜每次旅行的目的地)。 贝茜选择的第二短的路径中,可以包含任何一条在最短路中出现的道路,并且,一条路可以重复走多次。当然咯,第二短路的长度必须严格大于最短路(可能有多条)的长度,但它的长度必须不大于所有除最短路外的路径的长度。

输入输出格式

输入格式:

Line 1: Two space-separated integers: N and R

Lines 2..R+1: Each line contains three space-separated integers: A, B, and D that describe a road that connects intersections A and B and has length D (1 ≤ D ≤ 5000)

输出格式:

Line 1: The length of the second shortest path between node 1 and node N

输入输出样例

输入样例#1:  复制
4 4
1 2 100
2 4 200
2 3 250
3 4 100
输出样例#1:  复制
450

说明

Two routes: 1 -> 2 -> 4 (length 100+200=300) and 1 -> 2 -> 3 -> 4 (length 100+250+100=450)


这是一个持续了三天才写完的题……

深刻的理解了spfa的更新过程

spfa是将所有可以更新使得当前路径变短的下一个点都放入队列中,而不是像迪杰斯特拉一样用优先队列优先选择最短的路。

关于次短路的更新,第一天晚上对象说是再设置一个数组保存一下就好了啊……想想对……第二天没写出来

第二天晚上问具体是咋更新的,balabala……

今天写,就一直纠结是更新最短的时候加队列?那什么时候更新d2[]呢?看了老师写的博客,知道是但凡d[] d2[]能更新满足一个的情况就将下一个点加入队列

咋写都不对,网上基本上都是迪杰斯特拉写的,让我一度怀疑是不是spfa做不了,网上用spfa都是正着求一遍,反着求一遍,中间枚举每一个边,三段加一起第二短的是结果。

最后……终于发现了错误的根源!初始化不能写d2[s]=0!!!!

#include <iostream>
#include <queue>
#include <vector>
#include<cstdio>
#include<cstring>
using namespace std;
const long long inf=0x3f3f3f3f;
struct edge
{
    int to;
    long long cost;
};
vector <edge> g[200009];
int n,vis[20001];
long long d2[20001],d[20001];
queue<int> q;
long long spf1(int s)
{   edge tp;
    int u;
    for(int i=1;i<=n;i++)
        d[i]=inf,d2[i]=inf;
    memset(vis,0,sizeof(vis));
    d[s]=0;
  //  d2[s]=0;
    vis[s]=1;
    q.push(s);
    while(!q.empty())
    { u=q.front();
      q.pop();
      vis[u]=0;
      for(int i=0;i<g[u].size();i++)
      {
          tp=g[u][i];
          if(d[tp.to]>d[u]+tp.cost||(d[tp.to]<d[u]+tp.cost&&d2[tp.to]>d[u]+tp.cost)||d2[tp.to]>d2[u]+tp.cost&&d[tp.to]<d2[u]+tp.cost)
          {
              q.push(tp.to);
              if(d[tp.to]>d[u]+tp.cost)
                d[tp.to]=d[u]+tp.cost;
              if(d[tp.to]<d[u]+tp.cost&&d2[tp.to]>d[u]+tp.cost)
                d2[tp.to]=d[u]+tp.cost;
              if(d2[tp.to]>d2[u]+tp.cost&&d[tp.to]<d2[u]+tp.cost)
                d2[tp.to]=d2[u]+tp.cost;
          //  printf("to=%d,d=%lld,d2=%lld\n",tp.to,d[tp.to] ,d2[tp.to]);
          }
      //  printf("to=%d,d=%d,d2=%d\n",tp.to,d[tp.to],d2[tp.to]);
      }
    }
  return 0;
}
int main()
{
    int m,s,x;
   // freopen("testdata3.in","r",stdin);
    while(~scanf("%d%d",&n,&m))
    {
        int a,b;
        long long c;
       // printf("%d\n",inf);
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d%lld",&a,&b,&c);
            edge tmp;
            tmp.to=b;
            tmp.cost=c;
            g[a].push_back(tmp);
            tmp.to=a;
            g[b].push_back(tmp);
         }
         spf1(1);
        // for(int i=1;i<=n;i++) cout<<d2[i]<<" ";
        printf("%lld\n",d2[n]);
    }


    return 0;
}