Description
令F(x)=Sigma(i),1<=i<=x. 有一个不定方程f(x)+f(y)+f(z)+f(w)=N(0<=N<=10^12,x,y,z,w为自然数) 请统计方程的个数
Input
一个正数N
Output
一个数表示解的个数
Sample Input
input 1

2

input 2

4
Sample Output
output 1

6

output 2

13

解法:膜唐老师

///BZOJ 1429

#include <bits/stdc++.h>
using namespace std;
typedef long long LL;

int main(){
    LL n, ans;
    scanf("%lld", &n);
    n = n*2+1;
    ans = n+1;
    for(LL i=3; i<=n/i; i++){
        if(n%i==0){
            ans+=i;
            if(i!=n/i){
                ans+=n/i;
            }
        }
    }
    printf("%lld\n", ans);
    return 0;
}