The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices.

— It is a matter of security to change such things every now and then, to keep the enemy in the dark.

— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you >know!

— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door.

— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime! — I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds.

— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime. Now, the minister of finance, who had been eavesdropping, intervened.

— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound.

— Hmm, in that case I need a computer program to minimize the cost. You don’t know some very cheap software gurus, do you?

— In fact, I do. You see, there is this programming contest going on… Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above.
1033
1733
3733
3779
8779
8179
The cost of this solution is 6 pounds.
Note that the digit 1 which got pasted over in step 2 can not be
reused in the last step – a new 1 must be purchased.

Input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros)

Output

One line for each case, either with a number stating the minimal cost or containing the word Impossible.

Sample Input

3
1033 8179
1373 8017
1033 1033

Sample Output

6
7
0

题意:

给出两个四位数a和b,每次只变换原来那个数的一个数位上数字,变换后的数也必须是素数,(如1033、1733、 3733、 3739、 3779、 8779、 8179一共变了六次,且每一次只变数位上的一个数字,且变换后的数都是素数)问从a变到b最少需要多少次。

解题思路:

    很明显了,宽搜加枚举。由于是素数,所以个位肯定是奇数而且不能有前导0。

###代码:

#include <cstdio>
#include <queue>
#include <cstring>
//#define TEST

const int MAX = 10000 + 10;

bool book[MAX];
int step[MAX];

#ifdef TEST
int cnt = 0;
#endif // TEST

bool Is_Prime(int num)
{
    for (int i = 2; i * i <= num; i++) {
        if (num % i == 0) return false;
    }
    return true;
}

void Make(int New, int old, std::queue<int> &q)
{
    if (New != old && !book[New] && Is_Prime(New)) {
        q.push(New);
        book[New] = true;
        step[New] = step[old] + 1;
#ifdef TEST
        printf("New %d : %d\n", cnt++, New);
#endif // TEST
    }
}

void Find(int a, int b)
{
    int last = 0;
    std::queue<int> q;
    q.push(a);
    book[a] = true;
    step[a] = 0;
    while (!q.empty()) {
        last = q.front();
        q.pop();
        if (last == b) {
            printf("%d\n", step[last]);
            return;
        }
        for (int i = 1; i < 10; i += 2) { //枚举个位
            int New = last / 10 * 10 + i;
            Make(New, last, q);
        }
        for (int i = 0; i < 10; i++) {  //十位
            int New = last / 100 * 100 + i * 10 + last % 10;
            Make(New, last, q);
        }
        for (int i = 0; i < 10; i++) {  //百位
            int New = last / 1000 * 1000 + i * 100 + last % 100;
            Make(New, last, q);
        }
        for (int i = 1; i < 10; i++) {  //千位
            int New = i * 1000 + last % 1000;
            Make(New, last, q);
        }
    }
    printf("Impossible\n");
}

int main()
{
    int t = 0;
    scanf("%d", &t);
    while (t--) {
        memset(book, false, sizeof book);
        memset(step, 0, sizeof step);
        int a = 0, b = 0;
        scanf("%d%d", &a, &b);
        Find(a, b);
    }
    return 0;
}