Nightmare

题目链接:       杭电oj 1702

题目描述:

Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius' start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:
1. We can assume the labyrinth is a 2 array.
2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
3. If Ignatius get to the exit when the exploding time turns to 0, he can't get out of the labyrinth.
4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can't use the equipment to reset the bomb.
5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.

输入:

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth. There are five integers which indicate the different type of area in the labyrinth: 0: The area is a wall, Ignatius should not walk on it. 1: The area contains nothing, Ignatius can walk on it. 2: Ignatius' start position, Ignatius starts his escape from this position. 3: The exit of the labyrinth, Ignatius' target position. 4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.

输出:

For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.

 

样例输入:

3

3 3

2 1 1

1 1 0

1 1 3

4 8

2 1 1 0 1 1 1 0

1 0 4 1 1 0 4 1

1 0 0 0 0 0 0 1

1 1 1 4 1 1 1 3

5 8

1 2 1 1 1 1 1 4

1 0 0 0 1 0 0 1

1 4 1 0 1 1 0 1

1 0 0 0 0 3 0 1

1 1 4 1 1 1 1 1

 

样例输出:

4

-1

13

#include<iostream>
#include<cstring>
#include<queue>
#include<cstdio>
#define MAX 250
using namespace std;
int map[MAX][MAX];
int judge[MAX][MAX]={0}; 
int N,M;
int dir[4][2]={{0,1},{1,0},{0,-1},{-1,0}};//定义四个方向 

typedef struct PLACE{
int x;
int y;
int step;//记录步数 
int time;//记录剩余时间 
    bool operator <(const PLACE &a) const        //重载排序方法
        {
                return a.step<step;
        }
};//定义步数优先的结构体用于优先队列 

PLACE Ignatius;

void drow_map(int N,int M)
{
    int i,j;
    for(i=0;i<N;i++)
    {
        for(j=0;j<M;j++)
        {
            cin>>map[i][j];
            if(map[i][j]==2)	//找Ignatius的初始位置 
            {
                Ignatius.x=i;
                Ignatius.y=j;
                Ignatius.step=0;
                Ignatius.time=6;
                judge[i][j]=1;
            }
        }
    }
}

int main()
{
    int i,flag,step,door,n,life;
    priority_queue<PLACE> place;//定义步数优先的优先队列 
    PLACE place_deal,deal;   
    cin>>n;
    while(n--)
    {
    	flag=0;//用于标记是否到达出口 
    	life=1;//用于记录是否生存 
    	cin>>N>>M;
    	drow_map(N,M);//录入地图 
    	place.push(Ignatius);
    	while(!place.empty())
    	{
    		if(flag==1)
    		break;//到达出口 
    		place_deal=place.top();
    		place.pop();
    		for(int i=0;i<4;i++)//对当前位置的四个方向依次判断 
    		{
    			life=1;
    			deal.step=place_deal.step+1;
    			deal.x=place_deal.x+dir[i][0];
    			deal.y=place_deal.y+dir[i][1];
    			deal.time=place_deal.time-1;
    			if(deal.time==0)//当时间为0时炸弹爆炸,人物死亡 
    			life=0;
    			if(map[deal.x][deal.y]==4&&life==1)//对爆炸时间修改 
    			{
    				deal.time=6;
    			}
    			if(map[deal.x][deal.y]==3&&life==1)
    			{
    				flag=1;
    				step=deal.step;
    				break;
    			}
    			if(life==1&&deal.x>=0&&deal.x<N&&deal.y>=0&&deal.y<M&&(map[deal.x][deal.y]==1||map[deal.x][deal.y]==4))
    			{
    				if(map[deal.x][deal.y]==4)
    				map[deal.x][deal.y]=0;
    				place.push(deal);
    			}
    		}
    	}
    	
    	if(flag==1)
    	cout<<step<<endl;
    	else
    	cout<<"-1"<<endl;
    	while(!place.empty())
    	{
    		place.pop();
    	}
    	memset(map,0,sizeof(map));
    }
return 0;
}