Problem Description

A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy. 
Of course you know that it is vice versa. So you offer him to write a program that solves the “difficult” part.

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.

Input

The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard.

Output

For each test case, print one line saying “To get from xx to yy takes n knight moves.”.

Sample Input

e2 e4 
a1 b2 
b2 c3 
a1 h8 
a1 h7 
h8 a1 
b1 c3 
f6 f6

Sample Output

To get from e2 to e4 takes 2 knight moves. 
To get from a1 to b2 takes 4 knight moves. 
To get from b2 to c3 takes 2 knight moves. 
To get from a1 to h8 takes 6 knight moves. 
To get from a1 to h7 takes 5 knight moves. 
To get from h8 to a1 takes 6 knight moves. 
To get from b1 to c3 takes 1 knight moves. 
To get from f6 to f6 takes 0 knight moves.

题目大意:

有一个8*8的棋盘,棋盘的列用字母(a-h)表示,棋盘上的行用数字(1-8)表示。棋子只能走日字形(参考象棋中马的走法),输入数据有多组,每组有两个字符串分别为棋子初始位置和要到达的位置。问走的最小的步数。

#include <stdio.h>
#include <string.h>
#include <queue>
using namespace std;
int step;
int to[8][2] = {-2,1,-1,2,1,2,2,1,2,-1,1,-2,-1,-2,-2,-1};   //用来标记向8个方向的不同走法。
int map[10][10],ex,ey;
char s1[5],s2[5];
struct node
{
    int x,y,step;
};
int check(int x,int y)
{
    if(x<0 || y<0 || x>=8 || y>=8 || map[x][y])
    return 1;
    return 0;
}
int bfs()
{
    int i;
    queue<node> Q;
    node p,next,q;
    p.x = s1[0]-'a';
    p.y = s1[1]-'1';
    p.step = 0;
    ex = s2[0]-'a';
    ey = s2[1]-'1';
    memset(map,0,sizeof(map));
    map[p.x][p.y] = 1;
    Q.push(p);
    while(!Q.empty())
    {
        q = Q.front();
        Q.pop();
        if(q.x == ex && q.y == ey)
        return q.step;
        for(i = 0;i<8;i++)
        {
            next.x = q.x+to[i][0];
            next.y = q.y+to[i][1];
            if(next.x == ex && next.y == ey)
            return q.step+1;
            if(check(next.x,next.y))
            continue;
            next.step = q.step+1;
            map[next.x][next.y] = 1;
            Q.push(next);
        }
    }
    return 0;
}
int main()
{
    while(~scanf("%s%s",s1,s2))
    {
        printf("To get from %s to %s takes %d knight moves.\n",s1,s2,bfs());
    }
    return 0;
}