7-24 估值一亿的AI核心代码
以上图片来自新浪微博。
本题要求你实现一个稍微更值钱一点的 AI 英文问答程序,规则是:
- 无论用户说什么,首先把对方说的话在一行中原样打印出来;
- 消除原文中多余空格:把相邻单词间的多个空格换成 1 个空格,把行首尾的空格全部删掉,把标点符号前面的空格删掉;
- 把原文中所有大写英文字母变成小写,除了
I
; - 把原文中所有独立的
can you
、could you
对应地换成I can
、I could
—— 这里“独立”是指被空格或标点符号分隔开的单词; - 把原文中所有独立的
I
和me
换成you
; - 把原文中所有的问号
?
换成惊叹号!
; - 在一行中输出替换后的句子作为 AI 的回答。
输入格式:
输入首先在第一行给出不超过 10 的正整数 N,随后 N 行,每行给出一句不超过 1000 个字符的、以回车结尾的用户的对话,对话为非空字符串,仅包括字母、数字、空格、可见的半角标点符号。
输出格式:
按题面要求输出,每个 AI 的回答前要加上 AI:
和一个空格。
输入样例:
6
Hello ?
Good to chat with you
can you speak Chinese?
Really?
Could you show me 5
What Is this prime? I,don 't know
输出样例:
Hello ?
AI: hello!
Good to chat with you
AI: good to chat with you
can you speak Chinese?
AI: I can speak chinese!
Really?
AI: really!
Could you show me 5
AI: I could show you 5
What Is this prime? I,don 't know
AI: what Is this prime! you,don't know
#include<iostream>
using namespace std;
int main(){
int n;
string s;
cin>>n;
getchar();
while(n--){
getline(cin,s);
cout<<s<<endl<<"AI: ";
string t;
for(int i=0;i<s.size();i++){
if(s[i]>='a'&&s[i]<='z'||s[i]=='I'||s[i]>='0'&&s[i]<='9')t+=s[i];
else if(s[i]>='A'&&s[i]<='Z')t+=s[i]-'A'+'a';
else if(s[i]==' '&&t[t.size()-1]!=' '&&t.size()>0)t+=' ';
else if(s[i]!=' '){
if(t[t.size()-1]==' ')t[t.size()-1]=s[i];
else t+=s[i];
if(s[i]=='?')t[t.size()-1]='!';
}//cout<<t<<endl;
}
//cout<<t<<"****"<<endl;
string str;
for(int i=0;i<t.size();i++){
int flag=0;
/*
把原文中所有独立的 can you、could you 对应地换成 I can、I could
这里“独立”是指被空格或标点符号分隔开的单词;
把原文中所有独立的 I 和 me 换成 you
*/
if(i==0||t[i-1]==' '||t[i-1]==','){
string ss=t.substr(i,7);
//cout<<"((((("<<ss<<"))))))))"<<endl;
if(ss=="can you"&&(t[i+7]==' '||t[i+7]==',')){
str+="I can ";
if(t[i+7]==',')str[str.size()-1]=',';
i+=7;
flag=1;
}
ss=t.substr(i,9);
//cout<<"((((("<<ss<<"))))))))"<<endl;
if(ss=="could you"&&(t[i+9]==' '||t[i+9]==',')&&!flag){
str+="I could ";
if(t[i+9]==',')str[str.size()-1]=',';
i+=9;
flag=1;
//cout<<"**********"<<endl;
}
ss=t.substr(i,2);
//cout<<"((((("<<ss<<"))))))))"<<endl;
if(ss=="me"&&(t[i+2]==' '||t[i+2]==',')&&!flag){
str+="you ";
if(t[i+2]==',')str[str.size()-1]=',';
i+=2;
flag=1;
//cout<<"**********"<<endl;
}
ss=t.substr(i,1);
//cout<<"((((("<<ss<<"))))))))"<<endl;
if(ss=="I"&&(t[i+1]==' '||t[i+1]==',')&&!flag){
str+="you ";
if(t[i+1]==',')str[str.size()-1]=',';
i+=1;
flag=1;
//cout<<"**********"<<endl;
}
}
if(!flag){
str+=t[i];
}
}
cout<<str<<endl;
}
return 0;
}
借鉴的代码
天梯赛-L1-064 估值一亿的AI核心代码 (20 分)--2019全国CCCC天梯赛L1题解https://blog.csdn.net/qq_41464123/article/details/88926928
#include<iostream>
#include<algorithm>
#include<cstring>
#include<string>
#include<cmath>
using namespace std;
int d(char x)
{
if (x >= 'A'&&x <= 'Z') return -1;
if (x >= 'a'&&x <= 'z') return -2;
if (x >= '0'&&x <= '9') return -3;
if (x == ' ') return 2;
return 1;
}
string low(string str)
{
string b;
b += " ";
for (int i = 0; i < str.size(); i++)
{
if (str[i] >= 'A'&&str[i] <= 'Z'&&str[i] != 'I')
{
str[i] += 32;
}
if (str[i] == '?') str[i] = '!';
}
b += str;
b += " ";
str.clear();
str += " ";
for (int i = 1; i < b.size() - 1; i++)
{
if (b[i] == ' ' && b[i - 1] == ' ') continue;
else if (d(b[i + 1]) == 1 && b[i] == ' ') continue;
else str += b[i];
}
str += " ";
return str;
}
int main()
{
int t, i, j, k;
string str;
cin >> t;
getchar();
while (t--)
{
getline(cin, str);
cout << str << endl;
cout << "AI: ";
bool kong = false;
for (i = 0; i < str.size(); i++)
{
if (str[i] != ' ')
{
kong = true;
break;
}
}
if (kong == false)
{
cout << endl;
continue;
}
str = low(str);
string temp;
for (i = 0; i < str.size(); i++)
{
temp += str[i];
if (d(str[i])>0 && str[i + 1] == 'm'&&str[i + 2] == 'e'&&d(str[i + 3])>0)
{
i += 2;
temp += "you";
}
else if (d(str[i])>0 && str[i + 1] == 'I'&&d(str[i + 2])>0)
{
i++;
temp += "you";
}
else if (d(str[i])>0 && str[i + 1] == 'c'&& str[i + 2] == 'a'&& str[i + 3] == 'n'&& str[i + 5] == 'y'&& str[i + 6] == 'o'&& str[i + 7] == 'u'&&d(str[i + 8])>0)
{
i += 7;
temp += "I can";
}
else if (d(str[i])>0 && str[i + 1] == 'c'&& str[i + 2] == 'o'&& str[i + 3] == 'u'&& str[i + 4] == 'l'&& str[i + 5] == 'd'&& str[i + 7] == 'y'&& str[i + 8] == 'o'&& str[i + 9] == 'u'&&d(str[i + 10])>0)
{
i += 9;
temp += "I could";
}
}
str = "";
str += temp;
//cout << str << endl;
int len;
for (i = str.size() - 1; i >= 0; i--)
{
if (str[i] != ' ')
{
len = i;
break;
}
}
int cnt = 0;
for (i = 0; i <= len; i++)
{
if (i>0 && str[i] == ' '&& d(str[i + 1]) == 1) continue;
if (str[i] != ' ') cout << str[i], cnt++;
else if (cnt>0) cout << " ";
}
cout << endl;
}
return 0;
}