L1-039 古风排版 (20分)
中国的古人写文字,是从右向左竖向排版的。本题就请你编写程序,把一段文字按古风排版。
输入格式:
输入在第一行给出一个正整数N(<100),是每一列的字符数。第二行给出一个长度不超过1000的非空字符串,以回车结束。
输出格式:
按古风格式排版给定的字符串,每列N个字符(除了最后一列可能不足N个)。
输入样例:
4
This is a test case
输出样例:
asa T
st ih
e tsi
ce s
#include<bits/stdc++.h>
using namespace std;
int main()
{
int n;
cin>>n;
string s;
getchar();
getline(cin,s);
int i,j;
int count=0;
char a[1005][1005];
i=n;
if(s.length()%n!=0)
{
j=s.length()/n+1;
}
else{
j=s.length()/n;
}
int num=j;
for(j=num-1;j>=0;j--)
{
for(i=0;i<n;i++)
{
if(count<s.length())
{
a[i][j]=s[count];
count++;
}
else
a[i][j]=' ';
}
}
for(i=0;i<n;i++)
{
for(j=0;j<num;j++)
{
cout<<a[i][j];
}
puts("");
}
}