Let the Balloon Rise HDU1004

Let the Balloon Rise
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 155766 Accepted Submission(s): 61907

Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges’ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) – the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output
red
pink

题意:给你几个气球让你找出其中数量最多的那个颜色的气球(保证有唯一解)

#include<stdio.h>
#include<iostream>
#include<math.h>
#include<string.h>
#include<algorithm>
#include<string>
using namespace std;
struct balloon{
    string color;
    int number;
};
int main(){
    int n;//气球数
    while(cin>>n){
        if(n==0)break;
        balloon a[100];
        int cnt=0;//气球种数
        string x;
        int mx=0;//用来统计数量最多的颜色
        for(int i=1;i<=n;i++){
            cin>>x;
            int flag=0;
            for(int j=1;j<=cnt;j++){
                if(a[j].color==x){//如果已有同色气球就加一
                    flag=1;
                    a[j].number++;
                    mx=max(a[j].number,mx);
                    break;
                }
            }
            if(flag==0){//没有同色气球,就将种类加一,数量标为一
                a[++cnt].color=x;
                a[cnt].number=1;
                mx=max(a[cnt].number,mx);
            }
        }
        for(int i=1;i<=n;i++){//遍历一遍找到数量最多的气球种类
            if(a[i].number==mx){
                cout<<a[i].color<<endl;
                break;
            }
        }

    }
	return 0;
}