Problem Description

When Teddy was a child , he was always thinking about some simple math problems ,such as “What it’s 1 cup of water plus 1 pile of dough ..” , “100 yuan buy 100 pig” .etc..

One day Teddy met a old man in his dream , in that dream the man whose name was“RuLai” gave Teddy a problem :

Given an N , can you calculate how many ways to write N as i * j + i + j (0 < i <= j) ?

Teddy found the answer when N was less than 10…but if N get bigger , he found it was too difficult for him to solve. 
Well , you clever ACMers ,could you help little Teddy to solve this problem and let him have a good dream ?

Input

The first line contain a T(T <= 2000) . followed by T lines ,each line contain an integer N (0<=N <= 10[sup]10[/sup]).

Output

For each case, output the number of ways in one line.

Sample Input



3

Sample Output


1

题目大意:

给出一个数n,求 i * j + i + j = n(0 < i <= j)有多少种方法。

#include<iostream>
#include<cmath>
#include<cstdio>
using namespace std;
int main()
{
    long long int a,b,c,d,e,f,m;
    cin>>a;
    while(a--)
    {
        cin>>m;
        m++;
        b=sqrt(m);
        e=0;
        for(c=2;c<=b;c++)
        {
            if(m%c==0&&m/c>=c)
                e++;
        }
        cout<<e<<endl;
    }
    return 0;
}