题干:

Calculate the number of toys that land in each bin of a partitioned toy box. 
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys. 

John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box. 
 
For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
 5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2

Hint

As the example illustrates, toys that fall on the boundary of the box are "in" the box.

题目大意:

    在一个盒子内用挡板隔开给出挡板两端坐标和一些玩具的坐标输出落在每个方格中的玩具数量。

解题报告:

      通过叉积直接判断玩具点和直线的位置关系,从而确定玩具归属于哪一个格子,二分找位置,找到之后还要来一个if判断来确认这个位置是否正确(即做±1的微调)。再就是注意格式,输出之间需要一个空行。

AC代码:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>

using namespace std;
int n,m,x1,x2,y1,y2;
int ans[5005];
int top;
struct Point {
	int x,y;
	Point(){}
	Point(int x,int y):x(x),y(y){} 
} p[5005];
struct Edge {
	Point s,e;
	Edge(){}
	Edge(Point s,Point e):s(s),e(e){} 
} e[5005];

int xmult(Point o,Point a,Point b) {
	return (a.x-o.x) * (b.y-o.y) - (a.y-o.y) * (b.x-o.x);
}
int main()
{
	int xx1,xx2,xx,yy;
	while(~scanf("%d%d%d%d%d%d",&n,&m,&x1,&y1,&x2,&y2)) {
		if(n == 0) break;
		memset(ans,0,sizeof(ans));
		top = 0;
		for(int i = 1; i<=n; i++) {
			scanf("%d%d",&xx1,&xx2);
			e[i] = Edge(Point(xx1,y1),Point(xx2,y2));
		}
		e[n+1] = Edge(Point(x2,y1),Point(x2,y2)); 
		for(int i = 1; i<=m; i++) {
			scanf("%d%d",&xx,&yy);
			p[i] = Point(xx,yy);
		}
		int l,r,mid;
		for(int i = 1; i<=m; i++) {
			l = 1; r = n+1;//如果这里是r=n+1,那就必须加 35行的e[n+1] = Edge(Point(x2,y1),Point(x2,y2)); 这一句。但是这里也可以直接r=n,这样就不需要35行那句了并且也可以ac。想想为什么 
			mid = (l+r)/2;
			while(l<r) {
				mid = (l+r)/2;
				if(xmult(p[i],e[mid].s,e[mid].e) < 0) r = mid;
				else l = mid+1;
			}
			if(xmult(p[i],e[l].s,e[l].e) < 0) ans[l]++;
			else ans[l+1]++;
		}
		for(int i = 1; i<=n+1; i++) {
			printf("%d: %d\n",i-1,ans[i]);
		}
		puts(""); 
	}
	
	return 0 ;
}

今天又写了一遍:(也算是体会到判断ans[l]++或者ans[l+1]++的真正原因)

#include<cstdio>
#include<algorithm>
#include<iostream>
#include<cstring>
using namespace std;
int n,m,x1,x2,y1,y2;//n个板子,m个玩具,左上角,右下角。 

struct Edge {
	int x1,y1;//上 
	int x2,y2;//下 
} e[5005];
struct Node {
	int x,y;
} node[5005];
int ans[5005];
int cal(int tar,int line) {
	return (node[tar].x - e[line].x2)*(e[line].y1-e[line].y2) - (e[line].x1 - e[line].x2)*(node[tar].y - e[line].y2);
} 
int main()
{
	while(cin>>n) {
		if(n == 0) break;
		cin>>m>>x1>>y1>>x2>>y2;
		memset(ans,0,sizeof ans);
		for(int i = 1; i<=n; i++) {
			scanf("%d%d",&e[i].x1,&e[i].x2);
			e[i].y1 = y1;
			e[i].y2 = y2;
		}
		for(int i = 1; i<=m; i++) {
			scanf("%d%d",&node[i].x,&node[i].y);
		}
		//process each 
		for(int i = 1; i<=m; i++) {
			int l = 1,r = n;
			int mid = (l+r)/2;
			while(l<r) {
				mid = (l+r)/2;
				if(cal(i,mid) > 0) l=mid+1;
				else r=mid; 
			}
			if(l == n) {
				if(cal(i,l) < 0) ans[l]++;
				else ans[l+1]++;				
			}
			else ans[l]++;
		}
		for(int i = 1; i<=n+1; i++) {
			printf("%d: %d\n",i-1,ans[i]);
		}
		printf("\n");
	}
	return 0 ;
 }