MPI Maelstrom

 

BIT has recently taken delivery of their new supercomputer, a 32 processor Apollo Odyssey distributed shared memory machine with a hierarchical communication subsystem. Valentine McKee's research advisor, Jack Swigert, has asked her to benchmark the new system. 
``Since the Apollo is a distributed shared memory machine, memory access and communication times are not uniform,'' Valentine told Swigert. ``Communication is fast between processors that share the same memory subsystem, but it is slower between processors that are not on the same subsystem. Communication between the Apollo and machines in our lab is slower yet.'' 

``How is Apollo's port of the Message Passing Interface (MPI) working out?'' Swigert asked. 

``Not so well,'' Valentine replied. ``To do a broadcast of a message from one processor to all the other n-1 processors, they just do a sequence of n-1 sends. That really serializes things and kills the performance.'' 

``Is there anything you can do to fix that?'' 

``Yes,'' smiled Valentine. ``There is. Once the first processor has sent the message to another, those two can then send messages to two other hosts at the same time. Then there will be four hosts that can send, and so on.'' 

``Ah, so you can do the broadcast as a binary tree!'' 

``Not really a binary tree -- there are some particular features of our network that we should exploit. The interface cards we have allow each processor to simultaneously send messages to any number of the other processors connected to it. However, the messages don't necessarily arrive at the destinations at the same time -- there is a communication cost involved. In general, we need to take into account the communication costs for each link in our network topologies and plan accordingly to minimize the total time required to do a broadcast.''

Input

The input will describe the topology of a network connecting n processors. The first line of the input will be n, the number of processors, such that 1 <= n <= 100. 

The rest of the input defines an adjacency matrix, A. The adjacency matrix is square and of size n x n. Each of its entries will be either an integer or the character x. The value of A(i,j) indicates the expense of sending a message directly from node i to node j. A value of x for A(i,j) indicates that a message cannot be sent directly from node i to node j. 

Note that for a node to send a message to itself does not require network communication, so A(i,i) = 0 for 1 <= i <= n. Also, you may assume that the network is undirected (messages can go in either direction with equal overhead), so that A(i,j) = A(j,i). Thus only the entries on the (strictly) lower triangular portion of A will be supplied. 

The input to your program will be the lower triangular section of A. That is, the second line of input will contain one entry, A(2,1). The next line will contain two entries, A(3,1) and A(3,2), and so on.

Output

Your program should output the minimum communication time required to broadcast a message from the first processor to all the other processors.

Sample Input

5
50
30 5
100 20 50
10 x x 10

Sample Output

35

测试样例解析:

#include <stdio.h>
#include <string.h>
#define inf 0x3f3f3f3f
#define MAX 105
int dis[MAX],g[MAX][MAX],vis[MAX];
//dis数组用于记录从起点到i点的最短距离
//vis数组用于存放最短路径点
//g数组用于存放两点之间的距离 
int n;//n表示有多少个处理器 
 
int max(int a,int b)
{
	return a>b?a:b;
}


void Dijkstra(){//起点一定是1号点,由题可知 
	//初始化 
	for(int i = 1;i<=n;i++){
		vis[i] = 0;
		dis[i] = g[1][i];
	}
	//初始起始点到自己的距离为0,vis集合中只有起点 
	vis[1] = 1;dis[1] = 0; 
	
	for(int i = 1;i<n;i++){
		int temp = inf;
		int k=-1;
		for(int j=1;j<=n;j++){//找最小的dis[i],并记录下来 
			if(temp>dis[j] && !vis[j]){
				temp = dis[j];
				k = j;
			}
		}
		if(k==-1) //没有找到一个小于inf的边,说明此时集合vis和非vis集合不连通 
			break;
		vis[k] = 1;//将点k纳入vis集合中 
		for(int j =1;j<=n;j++){//更新dis数组,dis[j]表示从起点到点j的最短距离 
			if(!vis[j]&& dis[j]>dis[k]+g[k][j]){
				dis[j] = dis[k] + g[k][j];
			}
		}
	}
}

int main(){
	while(scanf("%d",&n)!=EOF){//五个处理器(五个点) 
		memset(g,inf,sizeof(g));//初始化所有点,即点与点暂无联系 
		
		char input[MAX];//输入数据时为字符串 
		for(int i=2;i<=n;i++){
		//自己到自己为0,由题可知从第二个点开始输入 
			for(int j=1;j<i;j++){
			/*
			* 输入的时候虽然是一行,但是判断时是按照一个元素一个元素的判断, 
			* 原因是一个字符串的判断时空格和回车 
			*/
				scanf("%s",input);
				//printf("%s\n",input);
				if(input[0]=='x')//x为没有路 
					g[i][j] = g[j][i] = inf;
				else{
					int sum = 0;
					for(int k = 0;k<strlen(input);k++){
						sum = sum*10+input[k]-'0';
					}	
					g[i][j] = g[j][i] = sum; 
				}
			}
		}
		Dijkstra();
		int ans = 0;
		for(int i=1;i<=n;i++)
		{
			ans = max(ans,dis[i]);
		}
		printf("%d\n",ans);
	}
	return 0;
}