Problem Description
There is a sorted sequence A of length n. Give you m queries, each one contains four integers, l1, r1, l2, r2. You should use the elements A[l1], A[l1+1] ... A[r1-1], A[r1] and A[l2], A[l2+1] ... A[r2-1], A[r2] to form a new sequence, and you need to find the median of the new sequence.
 

Input
First line contains a integer T, means the number of test cases. Each case begin with two integers n, m, means the length of the sequence and the number of queries. Each query contains two lines, first two integers l1, r1, next line two integers l2, r2, l1<=r1 and l2<=r2.
T is about 200.
For 90% of the data, n, m <= 100
For 10% of the data, n, m <= 100000
A[i] fits signed 32-bits int.
 

Output
For each query, output one line, the median of the query sequence, the answer should be accurate to one decimal point.
 

Sample Input
1 4 2 1 2 3 4 1 2 2 4 1 1 2 2
 

Sample Output
2.0 1.5

【解题方法】由于序列是有序的,按照l1<l2的顺序排好之后,分3种情况讨论即可,水题。具体看代码。

【AC 代码】


#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
typedef long long LL;
double a[200010];
double queryans(int l1,int r1,int l2,int r2,int x)
{
    if(r1<l2){//分离
        if(x<=r1-l1+1) return a[l1+x-1];
        else return a[l2+(x-(r1-l1+1))-1];
    }
    else if(r1>=r2){//完全重合
        if(x<=l2-l1) return a[l1+x-1];
        else if(x>r2-l1+1+r2-l2+1) return a[r2+x-(r2-l1+1+r2-l2+1)];
        else return a[l2-1+(x-(l2-l1)+1)/2];
    }
    else{//部分重合
        if(x<=l2-l1) return a[l1+x-1];
        else if(x>r1-l1+1+r1-l2+1) return a[r1+x-(r1-l1+1+r1-l2+1)];
        else return a[l2-1+(x-(l2-l1)+1)/2];
    }
}
int main()
{
    int T,n,m;
    int l1,r1,l2,r2;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        for(int i=1; i<=n; i++){
            scanf("%lf",&a[i]);
        }
        for(int i=1; i<=m; i++){
            scanf("%d%d%d%d",&l1,&r1,&l2,&r2);
            if(l1>l2) swap(l1,l2),swap(r1,r2);
            int len = (r1-l1+1)+(r2-l2+1);
            if(len%2==1){
                printf("%.1f\n",queryans(l1,r1,l2,r2,len/2+1));
            }else{
                printf("%.1f\n",(queryans(l1,r1,l2,r2,len/2)+queryans(l1,r1,l2,r2,len/2+1))/2.0);
            }
        }
    }
    return 0;
}