Subsequence

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 20916   Accepted: 8921

Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3

题意:给出一个长度为n的序列,求出序列中大于S的子串的最短长度。

 

代码:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<string>
#include<cmath>
#include<set>
#include<map>
using namespace std;
#define inf 0x3f3f3f3f
#define ll long long
#define closeio std::ios::sync_with_stdio(false)

int a[100005];
int main()
{
	int t,n,s,i;
	closeio;
	cin>>t;
	while(t--)
	{
		cin>>n>>s;
		int l=0,sum=0,len=inf;
		for(i=0;i<n;i++)
		{
			cin>>a[i];
			sum+=a[i];
			while(sum>=s&&l<i)        //每当sum的值大于s时,记录当前子串长度和l的位置,让sum所包含的数组不断向右移动,从而找出符合条件的最短子段
			{
				s-=a[l];
				len=min(len,i-l+1);
				l++;
			}
		}
		if(len==inf)
		cout<<0<<endl;
		else
		cout<<len<<endl;
	}
	return 0;
}