题目
蒜头君经营着一个不大的水果店。他认为生存之道就是经营最受顾客欢迎的水果。现在他想要一份水果销售情况的明细表,这样就可以很容易掌握所有水果的销售情况了。
蒜头君告诉你每一笔销售记录的水果名称,产地和销售的数量,请你帮他生成明细表。
输入格式
第一行是一个整数 <math> <semantics> <mrow> <mi> N </mi> <mo> ( </mo> <mn> 0 </mn> <mo> < </mo> <mi> N </mi> <mo> ≤ </mo> <mn> 1000 </mn> <mo> ) </mo> </mrow> <annotation encoding="application/x-tex"> N(0 < N \le 1000) </annotation> </semantics> </math>N(0<N≤1000),表示共有 <math> <semantics> <mrow> <mi> N </mi> </mrow> <annotation encoding="application/x-tex"> N </annotation> </semantics> </math>N 次成功的交易。
其后有 <math> <semantics> <mrow> <mi> N </mi> </mrow> <annotation encoding="application/x-tex"> N </annotation> </semantics> </math>N 行数据,每行表示一次交易,由水果名称(小写字母组成,长度不超过 <math> <semantics> <mrow> <mn> 100 </mn> </mrow> <annotation encoding="application/x-tex"> 100 </annotation> </semantics> </math>100),水果产地(小写字母组成,长度不超过 <math> <semantics> <mrow> <mn> 100 </mn> </mrow> <annotation encoding="application/x-tex"> 100 </annotation> </semantics> </math>100)和交易的水果数目(正整数,不超过 <math> <semantics> <mrow> <mn> 1000 </mn> </mrow> <annotation encoding="application/x-tex"> 1000 </annotation> </semantics> </math>1000)组成.
输出格式
请你输出一份排版格式正确(请分析样本输出)的水果销售情况明细表。这份明细表包括所有水果的产地、名称和销售数目的信息。水果先按产地分类,产地按字母顺序排列;同一产地的水果按照名称排序,名称按字母顺序排序。
样例输入
5
apple shandong 3
pineapple guangdong 1
sugarcane guangdong 1
pineapple guangdong 3
pineapple guangdong 1
样例输出
guangdong
|----pineapple(5)
|----sugarcane(1)
shandong
|----apple(3)
题解
最难的地方是建立映射关系,即水果名称、产地和销售的数量三者的关系
观察题意可以发现:
- 水果名称和销售的数量是一对一关系
- 产地与(水果名称和销售的数量)是一对多关系
所以一个水果名称与一个销售的数量是映射,一个产地与多对(水果名称和销售的数量)是映射,建立出映射表 map<string,map<string,int> >
#include<iostream>
#include<algorithm>
#include<map>
#include<string>
using namespace std;
int main(){
map<string,map<string,int> > m;
int n;
cin>>n;
string site,name;
int num;
for(int i=0;i<n;i++){
cin>>name>>site>>num;
if(m[site].count(name))
m[site][name] += num;
else
m[site][name] = num;
}
for(map<string,map<string,int> >::iterator it = m.begin();it != m.end();it++){
cout<<(it->first)<<endl;
for(map<string,int>::iterator itt = (it->second).begin();itt != (it->second).end();itt++)
cout<<" |----"<<(itt->first)<<"("<<(itt->second)<<")"<<endl;
}
return 0;
}