Tram

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 21769 Accepted: 8104

Description

Tram network in Zagreb consists of a number of intersections and rails connecting some of them. In every intersection there is a switch pointing to the one of the rails going out of the intersection. When the tram enters the intersection it can leave only in the direction the switch is pointing. If the driver wants to go some other way, he/she has to manually change the switch.

When a driver has do drive from intersection A to the intersection B he/she tries to choose the route that will minimize the number of times he/she will have to change the switches manually.

Write a program that will calculate the minimal number of switch changes necessary to travel from intersection A to intersection B.
Input

The first line of the input contains integers N, A and B, separated by a single blank character, 2 <= N <= 100, 1 <= A, B <= N, N is the number of intersections in the network, and intersections are numbered from 1 to N.

Each of the following N lines contain a sequence of integers separated by a single blank character. First number in the i-th line, Ki (0 <= Ki <= N-1), represents the number of rails going out of the i-th intersection. Next Ki numbers represents the intersections directly connected to the i-th intersection.Switch in the i-th intersection is initially pointing in the direction of the first intersection listed.
Output

The first and only line of the output should contain the target minimal number. If there is no route from A to B the line should contain the integer “-1”.
Sample Input

3 2 1
2 2 3
2 3 1
2 1 2
Sample Output

0

题目大意:有几个n个路口,每条路口连接了x条铁轨,连接的第一条铁轨是自动的不需要人控制,其他连接的铁轨的切换需要人工操作,问从a到b需要最少的人工操作次数。
思路:dijkstra可以跑出来关键在于矩阵的转化,我们可以将每个路口第一条路的权值设置为0,表示自动切换,其他的不是自动的权值设置为1,然后dijkstra跑一下就行了。
注意:g++wa,c++ac我也不知道什么鬼

#include<iostream>
#include<cstring>
using namespace std;
const int maxn=100+10;
const int inf=0x3f3f3f3f;

int dis[maxn];
int vis[maxn];
int e[maxn][maxn]; 
int n,a,b;
int dijkstra(int s){
	memset(vis,0,sizeof(dis));
	for(int i=1;i<=n;i++){
		dis[i]=e[s][i];
	// cout<<dis[i]<<" ";
	}
	dis[s]=0;vis[s]=1;
	for(int p=1;p<=n-1;p++){
		int minn=inf,k;
		for(int i=1;i<=n;i++){
			if(!vis[i]&&dis[i]<minn){
				minn=dis[i];
				k=i;
			}
		}
		vis[k]=1;
	// cout<<k<<endl;
		for(int i=1;i<=n;i++){
			if(!vis[i]&&dis[i]>dis[k]+e[k][i]){
				dis[i]=dis[k]+e[k][i];
			} 
		}
	}
	return dis[b];
}
int main(){
	cin>>n>>a>>b;
	int x,y;
	for(int i=1;i<=n;i++){
		for(int j=1;j<=n;j++){
			if(i==j)e[i][j]=0;
			else e[i][j]=inf;
		}
	}
	for(int i=1;i<=n;i++){
		cin>>x;
		for(int j=1;j<=x;j++){
			cin>>y;
			if(j==1) 
			e[i][y]=0;
			else{
				e[i][y]=1;
			}
		}
	}
	/*for(int i=1;i<=n;i++){ for(int j=1;j<=n;j++){ cout<<e[i][j]<<" "; } cout<<endl; }*/
	int ans=dijkstra(a);
	if(ans>=inf){
		cout<<"-1"<<endl;
	}else{
		cout<<ans<<endl;
	}
}