"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.

"But what is the characteristic of the special integer?" Ignatius asks.

"The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.

Can you find the special integer for Ignatius?

Input The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.
Output For each test case, you have to output only one line which contains the special number you have found.
Sample Input
5
1 3 2 3 3
11
1 1 1 1 1 5 5 5 5 5 5
7
1 1 1 1 1 1 1
Sample Output
3
5
1

大意就是在n个数中找到出现次数最多的数且满足大于一半。

题很简单,直接上代码

#include <iostream>
#include <string>
#include <sstream>
#include <stdio.h>
#include <stdlib.h>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <ctime>
#include <vector>
#include <set>
#include <sstream>
#include <map>
#include <cctype>

using namespace std;
#define Start clock_t start = clock();
#define End clock_t end = clock();
#define Print cout<<(double)(end-start)/CLOCKS_PER_SEC*1000<<"ºÁÃë"<<endl;

const int maxn = 1000000 + 5;
//a存输入的数据,b存出现的次数
int a[maxn],b[maxn];
int main()
{
    //Start;
    int n;
    while(cin>>n){
        memset(b,0,sizeof(b));
        for(int i = 0;i < n;i++){
            cin>>a[i];
        }
        int g = (n+1)/2;//
        for(int i = 0;i < n;i++){
            b[a[i]]++;
            if(b[a[i]] >= g) {//如果满足条件,输出并跳出循环
                cout<<a[i]<<endl;break;
            }
        }
        //End;
        //Print;

    }
    return 0;
}