3-7 表达式转换 (20 分)

算术表达式有前缀表示法、中缀表示法和后缀表示法等形式。日常使用的算术表达式是采用中缀表示法,即二元运算符位于两个运算数中间。请设计程序将中缀表达式转换为后缀表达式。

输入格式:

输入在一行中给出不含空格的中缀表达式,可包含+-*\以及左右括号(),表达式不超过20个字符。

输出格式:

在一行中输出转换后的后缀表达式,要求不同对象(运算数、运算符号)之间以空格分隔,但结尾不得有多余空格。

输入样例:

2+3*(7-4)+8/4

输出样例:

2 3 7 4 - * + 8 4 / +

不是我写的,我也不会现在~~~~~ 

#include <stdio.h>
#include<stdlib.h>
#include<string.h>
void MainFum(char*,int);
int compare(char,char);
int IsNum(char);
int ***(char);
int main() {
    char a[21];//表达式不超过20个字符
    scanf("%s",a);
    int len=strlen(a);
    MainFum(a,len);
    return 0;
}
int IsNum(char c) {return (c>='0'&&c<='9')||c=='.';}
int ***(char c) {return c=='+'||c=='-';}

int compare(char a,char b) {
    if(b==')')return 1;
    if(a=='('||b=='(')return 0;
    switch(b) {
        case '+':
        case '-':
            return 1;
        case '*':
        case '/':
            switch(a) {
                case '+':
                case '-':
                    return 0;
                case'*':
                case'/':
                    return 1;
            }
    }
}
void MainFum(char*a,int lenth) {
    static char stack[21];
    static int flag=0;//指示栈容
    static int i=0;//静态局部变量,用于标记当前处理到字符串的哪一个位置
    static int space =0;
    for(; i<lenth; i++) {
        if(IsNum(a[i])) {
            if(space) {
                printf(" ");
                space =0;
            }
            printf("%c",a[i]);
        } else if(***(a[i])&&(i?!IsNum(a[i-1])&&a[i-1]!=')':1)) {
            if(a[i]=='-') {
                if(space) {
                    printf(" ");
                    space =0;
                }
                printf("%c",a[i]);//正号不输出
            }
        } else { //一般符号
            if(flag) {
                if(a[i]==')')
                    while(flag--) {
                        if(stack[flag]=='(')break;
                        printf(" %c",stack[flag]);
                    }
                else {
                    while(flag) {
                        if(compare(stack[flag-1],a[i])) {
                            printf(" %c",stack[--flag]);
                        } else break;
                    }
                    stack[flag++]=a[i];
                }

            } else stack[flag++]=a[i];
            for(int j=0; j<flag; j++)
                if(stack[j]!='(') {
                    space=1;
                    break;
                }
        }
    }
    while(flag) {
        printf(" %c",stack[--flag]);
    }
}