Sample Input

ladder came tape soon leader acme RIDE lone Dreis peat

ScAlE orb eye Rides dealer NotE derail LaCeS drIed

noel dire Disk mace Rob dries

#

Sample Output

Disk

NotE

derail

drIed

eye

ladder

soon

题意:输入一些单词,找出所有满足如下条件的单词:该单词不能通过字母重排得到输入文本中的另一个单词。在判断是否满足条件时,字母不分大小写,但在输出时应保留输入中的大小写,按字典序进行排序(所有大写字母在小写字母前面)。

分析:关键在于“标准化”的思想和sort()函数的运用。

贴代码:

#include <iostream>
#include <string>
#include <sstream>
#include <stdio.h>
#include <stdlib.h>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <ctime>
#include <vector>
#include <set>
#include <sstream>
#include <map>
#include <cctype>
using namespace std;
#define Start clock_t start = clock();
#define End clock_t end = clock();
#define Print cout<<(double)(end-start)/CLOCKS_PER_SEC*1000<<"毫秒"<<endl;
map<string,int> cnt;
vector<string> words;

string repr(const string& s){
    string ans = s;
    for(int i = 0;i < ans.length();i++)
        ans[i] = tolower(ans[i]);
    sort(ans.begin(),ans.end());
    return ans;
}
int main()
{
    int n = 0;
    string s;
    while(cin>>s){
        if(s[0] == '#') break;
        words.push_back(s);
        string r = repr(s);
        if(!cnt.count(r)) cnt[r] = 0;
        cnt[r]++;
    }
    vector<string> ans;
    for(int i = 0;i < words.size();i++)
        if(cnt[repr(words[i])] == 1) ans.push_back(words[i]);
    sort(ans.begin(),ans.end());
    for(int i = 0;i < ans.size();i++)
        cout<<ans[i]<<endl;
    return 0;
}