Knight Moves
A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.
Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part.
Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.
Input
The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard.
Output
For each test case, print one line saying "To get from xx to yy takes n knight moves.".
Sample Input
e2 e4 a1 b2 b2 c3 a1 h8 a1 h7 h8 a1 b1 c3 f6 f6
Sample Output
To get from e2 to e4 takes 2 knight moves. To get from a1 to b2 takes 4 knight moves. To get from b2 to c3 takes 2 knight moves. To get from a1 to h8 takes 6 knight moves. To get from a1 to h7 takes 5 knight moves. To get from h8 to a1 takes 6 knight moves. To get from b1 to c3 takes 1 knight moves. To get from f6 to f6 takes 0 knight moves.
/*
* a b c d e f g h
* 1 0 0 0 0 0 0 0 0
* 2 0 0 0 0 a 0 0 0
* 3 0 0 0 0 0 0 c 0
* 4 0 0 0 0 b 0 0 0
* 5 0 0 0 0 0 0 0 0
* 6 0 0 0 0 0 0 0 0
* 7 0 0 0 0 0 0 0 0
* 8 0 0 0 0 0 0 0 0
* e2(a)-->e4(b) a-->c-->b
*
*/
#include <stdio.h>
#include <string.h>
#include <queue>
using namespace std;
int step; //记录跳动的总次数
int to[8][2] = {{-2,1},{-1,2},{1,2},{2,1},{2,-1},{1,-2},{-1,-2},{-2,-1}};//骑士移动的8个方位
int map[8][9]; //地图
int ex,ey; //终点坐标
char s1[2],s2[2]; //输入的两个点 s1 s2
struct node{
int x,y,step;
};
int check(int x,int y){ //判断是否可以跳
if(x<0 || y<0 || x>=8 || y>=8 || map[x][y])
return 1;
return 0;
}
int bfs(){
int i;
queue<node> Q;
node now,next;
memset(map,0,sizeof(map)); //初始化
//将输入的起始坐标给now,并标记该位置为已访问,将now压入队列
now.x = s1[0]-'a';
now.y = s1[1]-'1';
now.step = 0;
map[now.x][now.y] = 1;
Q.push(now);
//将输入的终点坐标给(ex,ey)
ex = s2[0]-'a';
ey = s2[1]-'1';
while(!Q.empty()){
now = Q.front(); Q.pop();//取出队列中第一个并将其弹出
if(now.x == ex && now.y == ey) //如果该点即为终点,则返回步数
return now.step;
for(i = 0;i<8;i++){
//从一个位置往所有能跳的方向跳动
next.x = now.x+to[i][0];
next.y = now.y+to[i][1];
if(next.x == ex && next.y == ey)
//如果跳动后的点为终点,则返回步数
return now.step+1;
if(check(next.x,next.y))
//检查跳过去的坐标是否是可以跳动的,不可以直接跳过该次循环
continue;
//如果跳过去的坐标满足条件
next.step = now.step+1;
map[next.x][next.y] = 1;
Q.push(next);
}
}
//国际象棋中没有一个位置是骑士(马)跳不到的位置的
return 0;
}
int main()
{
while(scanf("%s%s",s1,s2)!=EOF)
{
printf("To get from %s to %s takes %d knight moves.\n",s1,s2,bfs());
}
return 0;
}