7-22 堆栈模拟队列(25 分)

设已知有两个堆栈S1和S2,请用这两个堆栈模拟出一个队列Q。

所谓用堆栈模拟队列,实际上就是通过调用堆栈的下列操作函数:

int IsFull(Stack S):判断堆栈S是否已满,返回1或0;
int IsEmpty (Stack S ):判断堆栈S是否为空,返回1或0;
void Push(Stack S, ElementType item ):将元素item压入堆栈S;
ElementType Pop(Stack S ):删除并返回S的栈顶元素。
实现队列的操作,即入队void AddQ(ElementType item)和出队ElementType DeleteQ()。

输入格式:

输入首先给出两个正整数N1和N2,表示堆栈S1和S2的最大容量。随后给出一系列的队列操作:A item表示将item入列(这里假设item为整型数字);D表示出队操作;T表示输入结束。

输出格式:

对输入中的每个D操作,输出相应出队的数字,或者错误信息ERROR:Empty。如果入队操作无法执行,也需要输出ERROR:Full。每个输出占1行。

输入样例:

3 2
A 1 A 2 A 3 A 4 A 5 D A 6 D A 7 D A 8 D D D D T

输出样例:

ERROR:Full
1
ERROR:Full
2
3
4
7
8
ERROR:Empty

几种情况

记容量小的栈为s1,容量大的栈为s2

输入时
1. s1没满,s2为空,输入到s1中。
2. s1满了,s2为空,将s1中的数据倒入s2中,再输入到s1中。
3. s1满了,s2不为空,输出ERROR:Full。
输出时
1. s2不是空的,直接输出s2.top()。
2. s2是空的,s1不是空的,将s1中的元素倒入s2中,再输出s2.top()。
3. s2是空的,s1也是空的,输出ERROR:Empty。

其他细节自行理解。

AC代码

/* 提交时间 状态 分数 题目 编译器 耗时 用户 2018/7/13 15:15:48 答案正确 25 7-22 C++ (g++) 5 ms 17204111 测试点 结果 耗时 内存 0 答案正确 4 ms 404KB 1 答案正确 4 ms 404KB 2 答案正确 5 ms 380KB */
#include <iostream>
#include <stack>
using namespace std;
int main()
{
    stack<int>s1;
    stack<int>s2;
    int v1, v2;
    cin >> v1 >> v2;
    if (v1 > v2)
    {
        v1 ^= v2;
        v2 ^= v1;
        v1 ^= v2;
    }
    int num;
    char order;
    while (true)
    {
        cin >> order;
        if (order == 'T')
            exit(0);
        else if (order=='A')
        {
            cin >> num;
            if (s1.size() == v1)
            {
                if (s2.size() == 0)
                {
                    while (s1.size())
                    {
                        s2.push(s1.top());
                        s1.pop();
                    }
                    s1.push(num);
                }
                else
                {
                    cout << "ERROR:Full" << endl;
                    continue;
                }
            }
            else
            {
                s1.push(num);
            }
        }
        else if (order == 'D')
        {
            if (s2.size() == 0)
            {
                if (s1.size() == 0)
                {
                    cout << "ERROR:Empty" << endl;
                    continue;
                }
                else
                {
                    while (s1.size())
                    {
                        s2.push(s1.top());
                        s1.pop();
                    }
                }
            }
            cout << s2.top() << endl;
            s2.pop();
        }
    }
}