Description

The Global Aerial Research Centre has been allotted the task of building the fifth generation of mobile phone nets in Sweden. The most striking reason why they got the job, is their discovery of a new, highly noise resistant, antenna. It is called 4DAir, and comes in four types. Each type can only transmit and receive signals in a direction aligned with a (slightly skewed) latitudinal and longitudinal grid, because of the interacting electromagnetic field of the earth. The four types correspond to antennas operating in the directions north, west, south, and east, respectively. Below is an example picture of places of interest, depicted by twelve small rings, and nine 4DAir antennas depicted by ellipses covering them.

Obviously, it is desirable to use as few antennas as possible, but still provide coverage for each place of interest. We model the problem as follows: Let A be a rectangular matrix describing the surface of Sweden, where an entry of A either is a point of interest, which must be covered by at least one antenna, or empty space. Antennas can only be positioned at an entry in A. When an antenna is placed at row r and column c, this entry is considered covered, but also one of the neighbouring entries (c+1,r),(c,r+1),(c-1,r), or (c,r-1), is covered depending on the type chosen for this particular antenna. What is the least number of antennas for which there exists a placement in A such that all points of interest are covered?

Input

On the first row of input is a single positive integer n, specifying the number of scenarios that follow. Each scenario begins with a row containing two positive integers h and w, with 1 <= h <= 40 and 0 < w <= 10. Thereafter is a matrix presented, describing the points of interest in Sweden in the form of h lines, each containing w characters from the set ['*','o']. A '*'-character symbolises a point of interest, whereas a 'o'-character represents open space.

Output

For each scenario, output the minimum number of antennas necessary to cover all '*'-entries in the scenario's matrix, on a row of its own.

Sample Input

2
7 9
ooo**oooo
**oo*ooo*
o*oo**o**
ooooooooo
*******oo
o*o*oo*oo
*******oo
10 1
*
*
*
o
*
*
*
*
*
*

Sample Output

17
5

和上一个题

HDU 4185 Oil Skimming 【离散化二分匹配 黑白染色】

的差别在于,上一个题不能覆盖空白的点,这个题是必须覆盖所有的点

所以就是hungary()/2+tot-hungary()了呗注意uN vN是二分图的序号!!

#include <iostream>
    #include<cstdio>
    #include<cstring>
    #include<vector>
    using namespace std;
    #define M 550
    #define MAXN 409
    #define inf 0x3f3f3f3f
    int uN,vN;//u,v数目
    int g[MAXN][MAXN];
    int linker[MAXN];
    bool used[MAXN];
    bool dfs(int u)//从左边开始找增广路径
    {
        int v;
        for(v=0;v<vN;v++)//这个顶点编号从0开始,若要从1开始需要修改
          if(g[u][v]&&!used[v])
          {
              used[v]=true;
              if(linker[v]==-1||dfs(linker[v]))
              {//找增广路,反向
                  linker[v]=u;
                  return true;
              }
          }
        return false;//这个不要忘了,经常忘记这句
    }
    int hungary()
    {
       // puts("hungary");
        int res=0;
        int u;
        memset(linker,-1,sizeof(linker));
        for(u=0;u<uN;u++)
        {
            memset(used,0,sizeof(used));
            if(dfs(u)) res++;
         //   printf("u=%d,res=%d\n",u,res);}
        }
        return res;
    }
int col[50][50];
int main()
{
 //   freopen("cin.txt","r",stdin);
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&uN,&vN);
        char str[50][50];
        int tot=0;
        for(int i=0;i<uN;i++)
        {
            scanf("%s",str[i]);
            for(int j=0;j<vN;j++)
            {
                if(str[i][j]=='*')
                {
                  //  g[i][j]=1;
                    col[i][j]=tot;
                    tot++;
                }
             //   else g[i][j]=0;
            }
        }
        memset(g,0,sizeof(g));
        int dir[4][2]={1,0,0,1,-1,0,0,-1};
        for(int i=0;i<uN;i++)
        {
            for(int j=0;j<vN;j++)
            {
                if(str[i][j]=='*')
                {
                    for(int k=0;k<2;k++)
                    {
                        int tx=i+dir[k][0];
                        int ty=j+dir[k][1];
                        if(tx<0||tx>=uN||ty<0||ty>=vN||str[tx][ty]!='*')continue;
                        //printf("i=%d,j=%d,tx=%d,ty=%d,colij=%d,coltxty=%d\n",i,j,tx,ty,col[i][j],col[tx][ty]);
                        g[col[tx][ty]][col[i][j]]=1;
                        g[col[i][j]][col[tx][ty]]=1;
                    }
                }
            }
        }
        uN=vN=tot;
     //   for(int i=0;i<tot;i++)for(int j=0;j<tot;j++)printf("g=%d %c",g[i][j],j==tot-1?'\n':' ');
        printf("%d\n",hungary()/2+tot-hungary());
    }
    return 0;
}